Failed to mount after update

Hi, I’m new using Manjaro. And I encountered this problem when I couldn’t open/mount my home partition (where my important documents are stored) after I updated. How do I fix it?

Please return the output of the following:

cat /etc/fstab
[lucsumitro@luc-PC ~]$ lsblk
sda      8:0    0 465,8G  0 disk 
├─sda1   8:1    0     2G  0 part /boot
├─sda2   8:2    0     8G  0 part [SWAP]
├─sda3   8:3    0 396,9G  0 part 
└─sda4   8:4    0  58,8G  0 part /
sr0     11:0    1  1024M  0 rom  
[lucsumitro@luc-PC ~]$ blkid
/dev/sda1: UUID="427cd502-f159-4da9-895c-36b176aed3b5" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="97be5b6a-01"
/dev/sda2: UUID="fb5d5d02-1dac-4226-ba85-98294cc2b455" TYPE="swap" PARTUUID="97be5b6a-02"
/dev/sda3: BLOCK_SIZE="512" UUID="01D66C6617243080" TYPE="ntfs" PARTUUID="97be5b6a-03"
/dev/sda4: UUID="1b1106c1-7d02-4188-9866-bf666b4aa25c" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="97be5b6a-04"
[lucsumitro@luc-PC ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=427cd502-f159-4da9-895c-36b176aed3b5 /boot          ext4    defaults,noatime 0 2
UUID=fb5d5d02-1dac-4226-ba85-98294cc2b455 swap           swap    defaults,noatime 0 0
UUID=1b1106c1-7d02-4188-9866-bf666b4aa25c /              ext4    defaults,noatime 0 1

So, I guess that is supposed to be /home/ ?
I really would not suggest ntfs as a linux partition … for a number of reasons … one of them being that the only reliable way to repair it is using windoze.
Which is what I would suggest at this point - attempt repair … but you would want to use windoze for that.
The other thing to mention might be what driver you are using for ntfs (ntfs-3g?)

1 Like

Thank you for the suggestion. I’m relatively new using Manjaro, and I rarely explore it. I don’t know whether it is ntfs-3g or not, how do i check it?

The main thing would be to check for the package:

pacman -Qs ntfs

(you may noticed that things changed recently and ntfs-3g was used to enable read/write of ntfs … whereas recent kernels are built with support from ntfs3 … but there have been numerous reports of problems using it with many choosing to continue using ntfs-3g for now)

1 Like

Yes, it turns out it was installed. Should I change it and reinstall? or is there another alternative? . Forgive me, I’m really bad at this.

I suggest running some form of windoze and using chkdsk or similar.
Note: Do Not Use tools like ntfsfix for linux.
They are not as capable as tools built for windoze (ntfs is a proprietary windoze filesystem), and can even be destructive to your data.

thank you

You could try to disable the kernel-internal ntfs3 driver by:

echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf
sudo mkinitcpio -P
sudo update-grub

and reboot afterwards.


This partition doesn’t have a mount point. If this is your home partition you will need to create a mountpoint of /home for it. If it is NTFS, as cscs suggests, and also vefied by blkid, then that’s not ideal; it needs to be a native Linux filesystem wherever possible.

thank you, it worked!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.