Failed to load module "xapp-gtk3-module"

On Manjaro KDE, I installed Renode framework and it’s giving me this error:

Gtk-Message: Failed to load module “xapp-gtk3-module”

I think I have the module installed as I have /usr/lib/gtk-3.0/modules/

By the way I also had to install other modules, like appmenu-gtk-module, but this last error i tried everything I found (error seems rare) and nothing worked.

Where should I look? I am a newbie, feel free to suggest any docs I should look at.

Sounds like the package may have missing dependencies. I would create an issue upstream as the AUR package maintainer has included the dependencies the developer lists.

1 Like

Seems like this might be a more general issue with that module
After updating yesterday I get this error for several (packaged) gtk applications. Up to now I’ve at least found it in:

  • gmrun
  • ardour6
  • hexchat
  • xfce4-notes

The package community/xapp is installed - version 2.0.4-1

This might also be the problem for what a user reported here:


It seems that if (e.g. in a terminal), I remove references to xapp in the $GTK_MODULES environment variable, the error message disappears. For example in my case I have:


Then do:

$ export $GTK_MODULES=canberra-gtk-module

From this post on the Arch linux wiki I noticed that I have a file:


Which I never created or modified by hand, with this contents:

# This file is sourced by xinit(1) or a display manager's Xsession, not executed.

if [ -z "$GTK_MODULES" ] ; then


Not sure if it’s safe to remove that and what impact it could have. Would be good to understand what package created it.

Looks like the Xfce forums to me. :wink:

Like they mentioned there, the error should not affect functionality. I wouldn’t worry about it.

No, don’t go messing around with system files.

❯ pamac search ---files /etc/X11/xinit/xinitrc.d/
/etc/X11/xinit/xinitrc.d/ is owned by xapp

Is not related to AUR packages: so, the category should be changed.

Just for the record, since the last update of stable branch [Stable Update] 2020-12-30
I often see such message Failed to load module "xapp-gtk3-module" also with almost every applications (not only GTK apps, but also with QT apps).

I also have /usr/lib/gtk-3.0/modules/ and /etc/X11/xinit/xinitrc.d/ owned by xapp package.

I reported on Manjaro’s Gitlab:

Is fixed in the upstream:

commit 5739810550cbd10edf30b7e99c771c0822dd958c

I applyed this patch (for myself) and the warning message is gone.

1 Like

Good point. At first I thought it was a problem with renode-bin itself.

So, now, we’ll have to wait for xapp rebuild :slight_smile:

1 Like

3 posts were split to a new topic: Error when trying to launch Instagraph

Has been updated in the unstable branch: xapp-2.0.5-2: (would be better wait, if your not on the Unstable branch, for avoiding to mix packages of different branches)

1 Like

Ah of course :blush:

BTW it seems that temporarily commenting out all of that file


Solves the problem. It seems to be a file sourced which essentially adds stuff to the environment variable:

which on my system is now effectively:


(which also sems a bit weird… but that’s another story).

Actually I’m not sure if it’s related but when that error appeared I wasn’t getting notifications with HexChat.

Good to know :slight_smile:

Updated today to xapp-2.0.6-1, error no longer shows up.

Indeed: I was editing my reply accordingly to the recent update :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.