Failed to install nvidia proprietary drivers, target not found: linux59-nvidia-418xx

Whenever i try to install proprietary drivers it fails the installation.
i have tried running sudo pacman -Syyu to update repository list but still the same problem occurs.

here’s the log

[kamey@kamey-x541nc ~]$ sudo mhwd -a pci nonfree 0300

Using config ‘video-hybrid-intel-nvidia-418xx-bumblebee’ for device: 0000:00:02.0 (0300:8086:5a85) Display controller Intel Corporation HD Graphics 500
Installing video-hybrid-intel-nvidia-418xx-bumblebee…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-418xx-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases…
error: target not found: linux59-nvidia-418xx
core is up to date
extra is up to date
community is up to date
multilib is up to date
Error: pacman failed!
Error: script failed!

nvidia doesnt work with kernel 5.9
(thus it wouldnt surprise me if profiles or modules werent built for it)
Change your kernel, try again.

so i need to downgrade kernel?
should i wait, will nvidia work with the kernel 5.9 in the future?
what needs to be done?

Select/install kernel 5.8, then select it from grub during boot.

For more info … search around. Heres an example:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.