Failed to finalize live systems, loop devices, ignoring

Manjaro Live USB turns off a minute after booting. Both Gnome and KDE but works on other computers.

Broadcast message from root@manjaro-gnome (Fri 2022-08-19 10:39:52 UTC):
The system is going down for poweroff NOW!
67.684226) sd-umoun[1924]: Failed to unmount /oldroot : Device or resource busy 
67.686182) sd-umoun[1925]: Failed to unmount /oldroot/run/miso/bootmnt: Device or resource busy 62.682561) sd-umoun[1926]: Failed to unmount /oldroot/run: Device or resource busy 
67.691279) shutdown(1): Could not detach loopback dev/loop3: Device or resource busy 
67.691607) shutdown[1]: Could not detach loopback dev/loop2: Device or resource busy 
67.691768) shutdown[1]: Could not detach loopback dev/loop1: Device or resource busy 
67.691921] shutdown[1]: Could not detach loopback dev/loop0: Device or resource busy 
67.693902) shutdown[1]: Failed to finalize file systems, loop devices, ignoring.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

If it works on other computers, the thought comes to mind that it has got something to do with that particular hardware - but you didn’t give any information on it.

Those messages are perfectly normal. GNU/Linux is quite verbose.

I’m gonna refer you to this comment /oldroot fails to unmount, shutdown unaffected / Newbie Corner / Arch Linux Forums

The cause seems to be that the system can’t unload the nvidia modules before shutdown, so we add a hook to shutdown.

create a file

sudo nano /usr/lib/systemd/system-shutdown/nvidia.shutdown

# Remove all Nvidia modules on shutdown
for MODULE in nvidia_drm nvidia_modeset nvidia_uvm nvidia
    # we will have to check if the modules are still loaded because they aren't always
    if lsmod | grep "$MODULE" &> /dev/null ; then
      rmmod $MODULE

and make it executable.
sudo chmod +x /usr/lib/systemd/system-shutdown/nvidia.shutdown

Lenovo B57O
BIOS Version/Date LENOVO 44CN41WW, 18/08/2011
Processor : Intel(R) Core™ i3-2330M CPU @ 2.20GHz, 2200 Mhz, 2 Core(s), 4 Logical Processor(s)

It doesnt last longer than a minute in the Live USB so I’m not able to install or even type or change a setting.

It doesnt last longer than a minute in the Live USB so I’m not able to install or even type or change a setting. So I doubt i will be able to type all this before the system goes off. I’d appreciate it if you could show me how i can work around that

My laptop doesn’t have a nvidia GPU.

My suspicion was new and unsupported hardware, but

isn’t exactly new or exotic.

Since it works on other computers but not on this one
it still can be a hardware problem (faulty components).

I’d verify with another live USB (another distribution - any one will do, even a very tiny one to save on download time) - just to see whether the problem exists with another distro as well.

I have tried several distros, my suspicion is the battery. Its a plug and play machine since I have problems with the battery. I get a notification first thing on boot up. So Im wondering if theres any tweak i can make in the ISO so the laptop ignores the problem. It’s the same with all the distros though.

I do not know what that might mean to you - I cannot extract any meaning out of it. :man_shrugging:

I’d remove the battery and run it on AC line power - at least for the time being.
That is going to be my only guess.

Plug and Play here means, without direct power I can’t use the laptop since the laptop’s battery is probably dead. So upon boot up into the live USB environments of all the distros I have tried, I get a notification telling me how low my battery is and the Live USB sessions shutdowns some seconds into the boot up.

if the battery is no good anyway - and you know about it, and it creates issues …
remove it - as I suggested
… can’t help but suggest things that seem to logically follow from the available information …

Sure thing, I will try that. Thanks

I removed my battery and its working perfectly. Thank you all for the help