Failed to create greeter session

My gui is not working and when i
cat /var/log/lightdmlightdm.log
I get:
Seat seat0: Failed to find session configuration lightdm-gtk-greeter
Seat seat0: Failed to create greeter session

I don’t have an answer, but I do wonder why you’re using Lightdm with Plasma instead of the usual SDDM?

1 Like

I have no idea, though i cannot access my gui because it is no more working and i cannot change it. Can you help me?

was it working prior to this issue?
if yes, were you installing/uninstalling/updating/modifying something?

I was trying to switch from NVIDIA to integrated graphics…

In what manner?
What exactly did you do?

Further background may be helpful as well - as already noted the KDE edition uses SDDM by default, not lightdm.

1 Like

I don’t remeber well, I changedsome settings files.
If you need something i can run some commands for you

post output from:

mhwd -l -li
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"

and system info:
inxi -zav7

Of course. Those are the outputs:
mhwd -l -li —> Installed PCI configs:-------------------------------------------------------- -
ls /etc/modprobe.d —> nothing, just empty line
find /etc/X11/ -name "*.conf" —>


and finally:
inxi -zav7 —> System: Kernel: 6.1.31-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1. -

Your system is not up-to-date. The current 6.1 kernel is 6.1.53-1-MANJARO.

Update your system first before asking for assistance. Outdated systems are not (and cannot be) supported.

looking at the mhwd output you have installed all available open source drivers, which is not good…
also the inxi output shows that you have installed the nvidia drivers:

Device-2: NVIDIA GA107GLM [RTX A1000 Laptop GPU] vendor: Dell driver: nvidia v: 535.54.03

while the mhwd shows you dont have them, so you installed them from somewhere else than manjaro repos, which is also not good…
you are also using RAID instead of AHCI:

  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: N/A
    bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104

this is not related to your issue, but it can cause suspend/resume etc. issues…

also what aragorn is saying… why is your system not up to date? …

remove the vesa config:

sudo rm /etc/X11/mhwd.d/vesa.conf

remove these drivers:

sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-modesetting

reboot … this probably will fix your issue… but you will have other problems with the third party nvidia drivers down the line…

1 Like

Thank you. Do you have any advice for the NVIDIA drivers?

yes… remove the third party nvidia drivers… and then install the manjaro drivers:

sudo mhwd -a pci nonfree 0300


How do I remove the Nvidia drivers? Plus, I was thinking about using the integrated GPU alone. Do you think it’s worth it? (I would like to save battery)

check for instructions on how to remove it from where you downloaded them - i presume it was from the nvidia site…
i have also dual gpu laptop, and have disabled nvidia, since i really dont need it… so its for you to decide if its worth it, and do you need nvidia for something…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.