Failed to connect socket to '/var/run/libvirt/virtstoraged

Hi everyone.

I have been try to create an a virtual machine with qemu, libvirt, and libvirt-manager. However, been selected ISO file and clicked on “start”, I get an error such as mentioned in the title of this topic.

¿Could you help me?


Have you been following the guidance in Arch Wiki?

libvirt - ArchWiki

general configuration, group membership, service starting, network setup …

and maybe

QEMU - ArchWiki

It’s solved.

Yes, but I have no so time to read it slowly so I have needed some free days to understand, because my English level is not so high. Nevertheless I have get the solution, I just needed include my user as member of “libvirt” group.

Now I have got an other problem. When I want to create a virtual machine with a virtual network in bridge mode, I get an error like this:

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/”, line 65, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/”, line 2001, in _do_async_install
installer.start_install(guest, meter=meter)
File “/usr/share/virt-manager/virtinst/install/”, line 701, in start_install
domain = self._create_guest(
File “/usr/share/virt-manager/virtinst/install/”, line 649, in _create_guest
domain = self.conn.createXML(install_xml or final_xml, 0)
File “/usr/lib/python3.9/site-packages/”, line 4366, in createXML
raise libvirtError(‘virDomainCreateXML() failed’)
libvirt.libvirtError: Unable to get interface MTU on ‘MyServer’: Device does not exist

Dependencys are installed (I have checked wiki) and I don’t find the solution on “libvirt - ArchWiki” .

Do you know what could be happening?

Maybe we could tell something
if you told us what you did
how you tried to do the following:

First of all I start “libvirtd” demon with “systemctl”, then run virt-manager and continue all the process to create a virtual machine. However, before to finish that process, when I select network setting as “bridge” (attached image) and I click on “Finalizar” (“finish” in English) to start with the automated process of installation, I have got the error mentioned above.

I think you need to create a bridge device first.
This KB article from RH Access might help. :slightly_smiling_face:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.