Failed to Add Printer

I’ve already faced exactly this failure, but it was with Gnome. When I ran the commands below it resolved, but in Budgie it is not working, even restarting the computer Acer ES 15 Processor i5 Ram 4 GB, Printer all-in-one HP Deskjet Ink Advantage 2676.

sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

Well, before any moderator complains that I made a mistake in this post, I apologize in advance!!!

Have you tried to add the printer by accessing localhost:631 in your browser?
then Adminstration Tab-then AddPrinter or Find New Printer

No friend, because I didn’t need it when I had this same problem in Gnome.

I think this method has risks, as it asks for username and password, I believe the system administrator.

Yes the username is “root” and password is the “administrator password”.

You indicated your printer is an HP. Have you tried adding the printer through HP Device Manager?
Maybe in Device-Setup Device? How about in (Manjaro) Print Settings that also calls localhost and AFAIK asks for password, not username, via polkit.

When you spoke in Device-Setup Device, remembered that if I install System-config-printer solves the problem of failure. Thankful!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.