Failed to add Manjaro to EFI boot

Up until now my system was as follows:

I have windows 10 on one drive, and the other drive had Linux Mint on it.
The one with Mint on it was partitioned with a fat32 /boot partition, ext4 / partition, ext4 /home partition and a swap partition.

I’ve decided to format my “/” partition and install Manjaro into it, while keeping the rest intact.

The installation went smoothly, but I wasn’t sure It worked, so to check I’ve tried running efibootmgr
But I got

EFI variables are not supported on this system.

Which as I understand it means I have booted my installation USB key using legacy BIOS mode instead of under UEFI.
I’ve had both options from the boot menu, and picked the UEFI boot option initially, but was unable to boot (got some error followed by a sort of boot command prompt).

The non UEFI version booted fine, and I’ve installed Manjaro using it.

After failing to use efibootmgr, I’ve mounted my /boot partition to look what was written to it.

It shows the following:
EFI boot-repair initramfs-5.10-x86_64-fallback.img intel-ucode.img memtest86+
‘System Volume Information’ grub initramfs-5.10-x86_64.img linux510-x86_64.kver vmlinuz-5.10-x86_64
BOOT Microsoft ubuntu

bkpbootx64.efi  bootx64.efi  fbx64.efi

Boot  Recovery

BCD   kd_02_10df.dll  kd_02_1af4.dll       qps-ploc   
BCD.LOG       boot.stl        kd_02_10ec.dll  kd_02_8086.dll  memtest.efi  
BCD.LOG1      bootmgfw.efi     kd_02_1137.dll  kd_07_1415.dll         
BCD.LOG2      bootmgfw_.efi  en-US   kd_02_14e4.dll  kd_0C_8086.dll   winsipolicy.p7b
BOOTSTAT.DAT  bootmgr.efi   kd_02_15b3.dll  kdstub.dll      
Fonts  kd_02_1969.dll        
Resources  kd_02_19a2.dll  lt-LT  

<ttf files>

bootres.dll  en-US


bootmgfw.efi.mui  bootmgr.efi.mui  memtest.efi.mui


BOOTX64.CSV  grub.cfg  grubx64.efi  mmx64.efi  shimx64.efi

'./System Volume Information':



fonts  grub.cfg  grubenv  i386-pc  locale  themes


<mod files>

<mo files>


<some png files etc>


What makes me worried, is that the Manjaro kernel was written into /boot and not into /boot/EFI, I’ve got a feeling I wouldn’t be able to boot Manjaro properly using UEFI now.

Maybe I wasn’t able to boot in UEFI mode because I’ve created my USB with Unetbootin? I didn’t want to use dd or Rufus because I wanted to keep the other files on the disk…

Can I fix it from the live session in BIOS mode, or must I gain access to the UEFI mode to solve it?

Hi @cantfind ,
Welcome to the forum!

Maybe, the problem is there and you did not change the fat32 partition to /boot/efi and flaged as boot, esp as it is described in the Manjaro Guide, which is in the live session and also in the Manjaro wiki.
Installation Guides - Manjaro

The Manjaro guide does not take into account what to do when you have different hard drives. Then, you could try and search in the forum.
Questions about dual booting Windows after installing Manjaro - #2 by michaldybczak

Hope this help, regards

I did flag it as boot and set its mount to /boot (tried to set it to /boot/efi as was described, but the installer refused to recognize it as a place to install the bootloader to when I did that - it only worked with /boot).

After backing up my USB key and destroying all its data by using Rufus in DD mode, I was able to boot in UEFI mode and the installer worked according to the instructions (/boot/efi was an option).

So, for posterity I leave this (and maybe it should be mentioned in the guide as well) - You can’t choose the /boot/efi option if you boot your live USB in BIOS mode, it’s only available if you boot it in UEFI mode.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.