Failed Remount Root and Kernel at startup

Because I wanted to switch to BTRFS for all my systems I re-installed my laptop, I create an ISO with build-tools (KDE Full, Kernel5.4) and fired that up. System is working fine besides a few issues/question.

I have a message at boot time similar to this post: read here
System works fine it is just that those Failed message appear.

This is what the log says
journalctl -u systemd-remount-fs.service
-- Boot fd0adbca6aa74aa2947851d71750d392 -- okt 04 07:57:14 silverlaptop systemd-remount-fs[307]: mount: /: mount point not mounted or bad option.

From fstab:
UUID=4e8e317a-ffdd-4141-9677-cd943d2500b7 / btrfs subvol=/@,defaults,noatime,space_cache,autodefrag,compress=zstd,discard=async,ssd,commit=120 0 0
└─sda2 btrfs ROOT 4e8e317a-ffdd-4141-9677-cd943d2500b7 918,8G 1% /run/timeshift/backup
So one of the mount options must be wrong. But I do not know what is not allowed in that fstab line.

Any help, additional info would be much appreciated!

Insofar I can see, all of the mount options are valid, but don’t use autodefrag on an SSD ─ it’s pointless and it only generates more wear ─ and don’t use the discard option either. Use the fstrim.timer instead that comes with systemd ─ I believe Manjaro now enables it by default for new installations on SSDs.

in my fstab i mount subvol=@ without the slash, maybe thats the problem.

No, that won’t be it. There’s no slash in my own /etc/fstab either. The slash is only really needed for nested subvolumes, i.e. subvolumes within subvolumes. When your subvolumes are all at the highest level in the filesystem, the slash isn’t needed.

Edit 1: I’ve just checked my log, and there’s no error message. Whatever’s causing it on your machine must be something else. :thinking:

Edit 2: I believe to have recently read something similar that was solved by copying the contents of the @log subvolume back to /var/log on the root subvolume by way of a chroot from within the live session on the installer medium, and to then remove the @log subvolume altogether ─ i.e. delete the subvolume and remove its entry from /etc/fstab.

You could try that. :thinking:

By the way, you are using two separate accounts? That’s not normally allowed here on the forum.

Did you mean me? I have nothing todo with ddt3.

My apologies ─ 't was a case of mistaken identity. :wink:


Did you mean me? I have nothing todo with Hagen. :wink:

:smiley: Apart from the fact of course that Hagen spend time to help me solve my boot problem

Thank you! I will change these
But I am not sure about your last statement: The iso I used for installation was created Friday October 1st and this fstab was created during a “calamares driven installation” .

I will and will get back with the result .

1 Like

I tried in my fstab to mount / at subvol=/@ instead of subvol=@. Both works.

what’s the output of

sudo lsattr /var

Your /var/log and /var/cache should be +C attribute set, on all included subfolders and files.

1 Like

Yeah, but Calamares doesn’t always get it right, given that there’s so much variety in filesystems and partitioning schemes, as well as the difference between SSDs and HDDs. The Manjaro installer typically picks standard values that are known to work in the most common scenarios.

I’ll give you an example. When I installed this system here, it also used discard in the /etc/fstab entries for my SSD-based filesystems, and it installed and enabled tlp by default, because most of our members are using a laptop. So I needed to sanitize a few things post-install. :wink:

It is fixed, the lsattr and chattr -R +C did not solve the problem but changing the mount options did.

Not sure which attribute did it but this is what (a correctly working) fstab look like now:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=80B0-B46D                            /boot/efi      vfat    umask=0077 0 2
UUID=4e8e317a-ffdd-4141-9677-cd943d2500b7 /              btrfs   subvol=/@,defaults,noatime,space_cache,compress=zstd,ssd,commit=120 0 0
UUID=4e8e317a-ffdd-4141-9677-cd943d2500b7 /home          btrfs   subvol=/@home,defaults,noatime,space_cache,compress=zstd,ssd,commit=120 0 0
UUID=4e8e317a-ffdd-4141-9677-cd943d2500b7 /var/cache     btrfs   subvol=/@cache,defaults,noatime,space_cache,compress=zstd,ssd,commit=120 0 0
UUID=4e8e317a-ffdd-4141-9677-cd943d2500b7 /var/log       btrfs   subvol=/@log,defaults,noatime,space_cache,compress=zstd,ssd,commit=120 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Oh and I enabled fstrim.timer

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.