Failed Minecraft Launcher Installation

Hi, I just switched to Manjaro two days ago. I switched from Ubuntu and I’m not sure what I am supposed to do with a package I am trying to run. Before I switched I wrote down all the programs that I had installed so that I could install them when I switch operating systems. One of those was the minecraft launcher. I had installed it on Ubuntu no problem and when I booted into a live version of Manjaro I was able to install it as well. I git cloned the folder went into it and use the command “makepkg -si” to install it and it worked fine. I was able to run it and login and there was no issue. After fully installing Manjaro on my laptop I did the same procedure. I downloaded it yet again, I went into the directory, I used: “sudo pacman -Syu binutils” and “sudo pacman -Syu base-devel” to install fakeroot and other necessary packages. I installed the launcher with “sudo makepkg -si” and it went ok. Finally I ran the command “minecraft-launcher” to launch and I get a strange error.
terminate called after throwing an instance of 'std::length_error'
what(): basic_string::_M_replace_aux
Aborted (core dumped)
I have tried reinstalling minecraft-launcher and also the packages required for the “makepkg” command to work but to no avail.

I appreciate any help or advice given to me. I am new to arch based distros so forgive me if there is something obvious that I am failing to see.