Failed Manjaro update - Will this work?

Total newbie who was happy with Manjaro until update caused boot fail. Looks like I’m not the only one struggling with a grub problem after the last Manjaro update. I see solutions involving chroot. Before I go that route some questions:

  1. I have BIOS (no UEFI) is this an issue?
  2. Unrelated (I think) boot looks for a USB drive that was removed because it was too small for timeshift.
  3. What if I try a workaround by restoring with my Timeshift external SSD? I have done this once and was able to recover my original install.
  4. Is the boot fail caused by kernel upgrade?
  5. If I use Timeshift back to previous version then update with sudo pacman -Syu or sudo pacman -Syyu? This got me back to grub fail but would it work because of new update version?
  6. What if I Timeshift back and don’t do version updates? Answers to any of those questions would be helpful as would suggestion that I keep digging through topics.

can you reports

inxi -Fxza
sudo parted -l 
df -Th

This is my first time working a problem here. The inxi is long, is this enough or do you need it all?

i think your motherboard cant boot in UEFI
you have bios , not UEFI one

boot on USB iso manjaro ( live )
add lts kernels

sudo manjaro-chroot -a ( type 1 if only 0 line appears )
pacman-mirrors -c all
pacman -Syy
mhwd-kernel -i linux54
mhwd-kernel -i linux419
pacman -S linux54-headers linux419-headers 
pacman -Syyu
exit ( end-chroot )

press Esc on reboot , in Grub , go in advanced section
choose 5.4 ou 4.19 LTS for boot


What was the error message or when exactly did you found the system failing? Details are important.

No. My system also runs with BIOS and msdos parted disk.

Could allow you to boot again, but you won’t know why it failed now.

Possible, but there could be hundreds of other reasons.

Please, provide all parts of the inxi output. Ideally by copying the text rather than making pictures and follow @stephane’s advice.

1 Like

Thank you for the prompt reply and your help. Entered information carefully and got errors on everything yesterday. Tried again today after double checking my wired connection and got the same result. Not one mirror connected. The only thing I did differently was the items in parentheses.

do not copy (…) it for comment , copy command just before

Thank you! Going down the list that you kindly replied to: System failed to boot Manjaro 20.0 ‘Lysia’ with the graphical update (not terminal). I am not dual booting. Unfortunately Stephanie’s advice resulted in failure to connect to mirrors (twice).

Here’s the complete inxi text:

[manjaro@manjaro ~]$ inxi -Fxza
Host: manjaro Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 9.3.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
misobasedir=manjaro misolabel=MANJARO_XFCE_200 quiet systemd.show_status=1
apparmor=1 security=apparmor
Desktop: Xfce 4.14.2 Distro: Manjaro Linux
Type: Desktop Mobo: ASUSTeK model: P6T SE v: Rev 1.xx serial:
BIOS: American Megatrends v: 0805 date: 02/24/2010
Topology: Quad Core model: Intel Core i7 930 bits: 64 type: MT MCP
arch: Nehalem family: 6 model-id: 1A (26) stepping: 5 microcode: 1D
L2 cache: 8192 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44916
Speed: 1604 MHz min/max: 1600/2801 MHz Core speeds (MHz): 1: 1604 2: 1604
3: 1671 4: 1632 5: 1633 6: 1613 7: 1873 8: 1625
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: tsx_async_abort status: Not affected
Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730]
vendor: Hightech Information System driver: radeon v: kernel
bus ID: 02:00.0
Display: x11 server: X.Org 1.20.8 driver: ati,radeon unloaded: modesetting
resolution: 1366x768~60Hz
OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 5.6.7-1-MANJARO LLVM 10.0.0)
v: 3.3 Mesa 20.0.5 direct render: Yes
Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series]
vendor: Hightech Information System driver: snd_hda_intel v: kernel
bus ID: 02:00.1
Sound Server: ALSA v: k5.6.7-1-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK M3A78 Series driver: r8169 v: kernel port: d800
bus ID: 06:00.0
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Realtek RTL-8185 IEEE 802.11a/b/g Wireless LAN
vendor: Abocom Systems driver: rtl818x_pci v: kernel port: e800
bus ID: 08:00.0
IF: wlp8s0 state: up mac:
Local Storage: total: 611.08 GiB used: 293.4 MiB (0.0%)
ID-1: /dev/sda vendor: Western Digital model: WD6400AAKS-22A7B2
size: 596.17 GiB block size: physical: 512 B logical: 512 B
ID-2: /dev/sdf type: USB vendor: SanDisk model: Cruzer Glide
size: 14.91 GiB block size: physical: 512 B logical: 512 B
ID-1: / raw size: N/A size: 8.77 GiB used: 293.4 MiB (3.3%) fs: overlay
source: ERR-102
System Temperatures: cpu: 48.0 C mobo: N/A gpu: radeon temp: 45 C
Fan Speeds (RPM): N/A gpu: radeon fan: 0
Processes: 239 Uptime: 1h 42m Memory: 11.69 GiB used: 1.58 GiB (13.5%)
Init: systemd Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 inxi: 3.0.37
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA WDC WD6400AAKS-2 (scsi)
Disk /dev/sda: 640GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 640GB 640GB primary ext4 boot

Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sdf: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2815MB 2819MB 4194kB primary esp

[manjaro@manjaro ~]$ df -Th


Can always chroot into your system with a Live USB and update everything successfully!

Please provide me the result of lsblk in order for me to guide you through the steps!

Have a sweet day!:chocolate_bar:

[manjaro@manjaro ~]$ lsblk
loop0 7:0 0 72.6M 1 loop /run/miso/sfs/livefs
loop1 7:1 0 578.7M 1 loop /run/miso/sfs/mhwdfs
loop2 7:2 0 1.4G 1 loop /run/miso/sfs/desktopfs
loop3 7:3 0 583.9M 1 loop /run/miso/sfs/rootfs
sda 8:0 0 596.2G 0 disk
└─sda1 8:1 0 596.2G 0 part /mnt
sdf 8:80 0 14.9G 0 disk
├─sdf1 8:81 0 2.6G 0 part /run/miso/bootmnt
└─sdf2 8:82 0 4M 0 part
sr0 11:0 1 1024M 0 rom
[manjaro@manjaro ~]$

Thank you!

In the terminal, punch in sudo -i , then press enter and give your password.
Once inside root, punch in the whole following command: mkdir /1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && cp /etc/resolv.conf /1/etc && chroot /1

When it asks you if you want to overwrite /etc/resolv.conf , type in yes.

Once inside, try executing sudo pacman -Syyu && grup-mkconfig !

Let me know if it worked!

1 Like

No option to overwrite?

[manjaro ~]# mkdir /1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && cp /etc/resolv.conf /1/etc && chroot /1
cp: not writing through dangling symlink ‘/1/etc/resolv.conf’
[manjaro ~]#

Hm, interesting! Try the command without it, then :thinking:

mkdir /1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1

1 Like

[manjaro ~]# mkdir /1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1
mkdir: cannot create directory ‘/1’: File exists
[manjaro ~]#

Since the mkdir command worked, I shouldn’t have made you retype it. My sincere apologize.

mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1


No apology needed. I’m delighted to get help!

mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1
mount: /1: /dev/sda1 already mounted on /mnt.

Alright, lets reset everything.

umount -l /dev/sda1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1

1 Like

Done. Needed six characters so this is what I entered:

manjaro ~]# umount -l /dev/sda1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1

The command worked, may I ask?

1 Like

manjaro ~]# umount -l /dev/sda1 && mount /dev/sda1 /1 && mount --bind /proc /1/proc && mount --bind /dev /1/dev && mount --bind /sys /1/sys && chroot /1
[manjaro /]#