Fail to update and now cannot use (517 to 518)

Hi, I tried to upgrade from 517 to 518/517, but seems failed and want to get back to 517, however, I could not find the nvidia driver. The output of nvidia-smi is

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

and output of pacman -Qs linux517- is

local/linux517-headers 5.17.15-1
    Header files and scripts for building modules for Linux517 kernel

output of sudo pacman -S linux517-nvidia
is error: target not found: linux517-nvidia. What can I do for now? Thank you!

1 Like

Kernel 5.17 is EOL (“end of life”).

1 Like

oh no, I am using that pretty well before… then what I can do?

considering that there were wifi, sound and driver issues at my laptop for using any previous kernel (i.e. <157)

ok I removed 517 and upgraded to 518, but after sudo pacman -S linux518-nvidia and sudo mkinitcpio -P and reboot, then it will not let me login but freezed at the black screen with a _ only. What can I do now?

Best to stick with the latest “LTS” kernel; otherwise, keep jumping to the latest “stable” kernel. In this case, 5.19. Not sure why you went with 5.18.

Use the Manjaro Kernel tool to manage kernels. It should automatically pull in the appropriate nvidia driver.

now the problem is that I cannot boot into the system and no terminal I can use even

You can boot into a live USB session, then “chroot” into your Manjaro installation, and from there either use Timeshift (command-line mode) to restore a snapshot, or use mhwd, mhwd-kernel, pamac, mkinitcpio, and update-grub to make the system bootable again.

sorry I am new to this, could you elaborate this more, with some detailed commands and explanations please?

Means: Boot a Manjaro Installation Disk, open a terminal and type sudo manjaro-chroot -a to switch to your local installation within that terminal session. If your system partition is btrfs, zfs or encrypted, then you need to mount it manually and switch like this: sudo manjaro-chroot /target /bin/bash

If you have snapshots then:

timeshift --restore

Install a kernel for example:

mhwd-kernel -i linux515

seems I couldn’t chroot due to the error can’t create chroot on non-directory. And yes I have the timeshift, but it needs to chroot first?


lsblk --fs



I see it now… :man_facepalming: It must be:

sudo manjaro-chroot -a

Then it will detect it automatically.

And please avoid pictures of text in the future. You can perfectly copy&paste it here from the terminal.

gotcha, now I’m in. there’s no internet in 5.15 kernel version for my laptop… anyway what’s next? just do timeshift --restore? I saw that the data in the partition looks good though?

well, I tried timeshift --restore, there’s nothing there as expected (it’s in efi?)

Is your timeshift drive /dev/nvme0n1p5 included in your chroot? Otherwise it will not work… I use normally btrfs where the snapshots are on the same drive. Anyway… just to explain: Timeshift is not really a backup tool, think more of “system recovery” in windows. Therefore it is always better to have such snapshots on the same partition.

I see, seems they are not in the same partition. ok, then back to the question, how can I get back booting to this partition?

Then skip timeshift here… the kernel is the problem now… while in chroot do:

mhwd-kernel -l && mhwd-kernel -li

This will give a list of installable and installed kernels.
Then install a stable or lts kernel:

mhwd-kernel -i linux515
mhwd-kernel -i linux519

linux517 and linux518 is not there anymore: EOL (end of life)

there’s only 515 shown there, which is the kernel version of the live boost. Does this good (original manjaro should be 518 I think?)? Also, I connected with my iPhone, but there errors: failed to initialize alpm library (root: /, dbpath: /var/lib/pacman), could not find or read directory.

Well without a working internet connection it will be really difficult… the live session must have working internet connection.

now I got internert, still the same error

Ok please post the full output please since you have internet now :slight_smile: So that I can follow your steps…