Fail to Start Simple Desktop Display Manager and Hangs on Reboot

I have a triple boot PC (macOS Big Sur, Windows 10, Manjaro), with each OS installed on independent SSDs. I installed each individually with the other SSDs disconnected during installation to avoid problems with each others EFI partitions. I am using the OpenCore boot loader.

Manjaro boots normally from the OpenCore boot loader. I added a MX Master mouse via Bluetooth, which is working fine. The only problem I see is that my Ethernet and Wifi is not working properly, but I will troubleshoot that later. My main issue is that once I am in Manjaro, I am unable to reboot properly.

When I reboot Manjaro, I get a screen with the text below. It fails to boot Simple Desktop Displaty Manager, and then it appears to be verifying Bluetooth and USB drives, and then freezes.

[3.507606] amdgpu 0000:03:00.0: amdgpu: ring comp_1.1.0 uses VM inv	eng 4 on	hub 0
[3.507650] amdgpu 0000:03:00.0: amdgpu: ring comp_1.2.0 uses VM inv	eng 5 on hub 0
[3.507695] amdgpu 0000:03:00.0: amdgpu: ring comp_1.3.0 uses VM inv	eng 6 on hub 0
[3.507741] amdgpu 0000:03:00.0; amdgpu: ring comp_1.0.1 uses VM inv	eng 7 on hub 0
[3.507786] amdgpu 0000:03:00.0: amdgpu: ring comp_1.1.1 uses VM inv	eng 8 on hub 0
[3.507831] amdgpu 0000:03:00.0: amdgpu: ring comp_1.2.1 uses VM inv	eng 9 on hub 0
[3.507876] amdgpu 0000:03:00.0: amdgpu: ring comp_1.3.1 uses VM inv	eng 10 on hub 0
[3.507922] amdgpu 0000:03:00.0: amdgpu: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[3.507968] amdgpu 0000:03:00.0: amdgpu: ring sdma0 uses VM inv eng 12 on hub 0
[3.508011] amdgpu 0000:03:00.0: amdgpu: ring sdmal uses VM inv eng 13 on hub 0
[3.509303] amdgpu 0000:03:00.0: amdgpu: ring vcn_dec uses VM inv eng 0 on hub 1
[3.510586] amdgpu 0000:03:00.0: amdgpu: ring vcn_enc0 uses VM inv eng 1 on hub 1 ring vcn_encl uses VM inv eng 4 on hub 1
[3.512101] amdgpu 0000:03:00.0: amdgpu: ring vcn_enc1 uses VM inv eng 4 on hub 1 
[3.513561] amdgpu 0000:03:00.0: amdgpu: ring jpeg_dec uses VM inv eng 5 on hub 1 
[3.515458] input: Massdrop Inc, ALT Keyboard Consumer Control as /devices/pci0000:00/0000:00:14.0/usbl/l-8/l-8.2/l-8.2:1.1/0003:04D8:EED3.0004/input/input16 
[3.515635] [drm] Initialized amdgpu 3.39.0 20150101 for 0000:03:00.0 on minor 1
[3.517125] hid-generic 0003:04D8:EED3.0004: input,hidraw3: USB HID v1.11 Device [Massdrop Inc. ALT Keyboard] on usb-0000:00:14.0-8.2/input1
[3.519916] input: Massdrop Inc. RLT Keyboard as /devices/pci0000:00/0000:00:14.0/usbl/l-8/l-8.2/l-8.2:1.2/0003:04D8:EED3.0005/input/input17 
[3.577647] hid-generic 0003:04D8:EED3.0005: input,hidraw4: USB HID v1.11 Keyboard [Massdrop Inc. HLT Keyboard] on usb-0000:00:14.0-8.2/input2 [3.581172] input: HID 05ac:820a as /devices/pci0000:00/0000:00:14.0/usb1/1-14/1-14.1/1-14.1:1.0/0003:05RC:8208.0006/input/input18 
[3.641101] hid-generic 0003:05HC:8208.0006: input,hidraw5: USB HID v1.11 Keyboard [HID 05ac:820a] on usb-0000:00:14.0-14.l/input0 
[3.647527] input: HID 05ac:820b as /devices/pci0000:00/0000:00:14.0/usb1/l-14/l-14.2/l-14.2:1.0/0003:05RC:820B.0007/input/input19 
[3.649716] hid-generic 0003:05RC:820B.0007: input,hidraw6: USB HID v1.11 Mouse [HID 05ac:820b] on usb-0000:00:14.0-14.2/input0
[FAILED] Failed to start Simple Desktop Display Manager.
[4.241117] usbcore: registered new device driver apple-mfi-fastcharge [4.250674] mousedev: PS/2 mouse device common for all mice 
[4.270615] Bluetooth: Core ver 2.22
[4.272173] NET: Registered protocol family 31
[4.273662] Bluetooth: HCI device and connection manager initialized [4.275207] Bluetooth: HCI socket layer initialized
[4.276716] Bluetooth: L2CRP socket layer initialized
[4.278216] Bluetooth: SCO socket layer initialized 
[4.370830] usbcore: registered new interface driver btusb 
[4.415398] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 
[4.421180]  Bluetooth: BNEP filters: protocol multicast 
[4.422740] Bluetooth: BNEP socket layer initialized
[4.435416] usb 1-14.1: USB disconnect, device number 6
[4.482208] Bluetooth: hci0: BCM: chip id 73 build 1125
[4.488188] Bluetooth: hci0: BCM: product 05ac:828d 
[4.494138] Bluetooth: hci0: BCM: features 0x07
[4.511231] Bluetooth: hci0: matt-linux
[4.571059] NET: Registered protocol family 38
[4.747715] usb 1-14:2: USB disconnect, device number 7

Any idea as to why the display manager fails to load? My goal is to be able to boot and reboot into Manjaro normally.

Since you mentioned

Boot Manjaro from that SSD with the default provided Boot Loader and see if things go better.
Here is how to provide good information:

so we know what kernel you use, and how you are with the updates…

1 Like

Thank you for the feedback. I changed my BIOS to boot directly into Manjaro and it booted fine. Sorry - I am new to Linux, but enjoying it so far.

To add Manjaro to OpenCore menu entry see this.

1 Like

Thanks - I actually used that guide. It worked at first, but then I ran into problems when trying to boot into Manjaro from the OpenCore picker. For now, I am booting directly into Manjaro when I need it. I would love to fix this issue with OpenCore eventually.

Not sure if is not a problem of the order the drives are initialized, hence the map table change … but yeah, the safest way is to boot directly the drive Manjaro is installed on.

Ok - I stand corrected. I think the problem above happened because I connected my MX Master 3 mouse via Bluetooth in Manjaro, but still didn’t have the Realtek ethernet and Broadcom wifi drivers working properly.

I just managed to configure those drivers correctly today - thanks to some help from this post - and now OpenCore boots normally in Manjaro.

So, I have a perfectly working triple boot machine and I’m lovin’ it!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.