Facing very slow boot time

Hi!
I am fairly new to Manjaro. Having a fine time with it. But the boot time is very slow!
I have turned down the grub timeout as well.

Still it takes like 23-25 seconds to boot up.

My specs are - i5 3.5 GHz ( I do not remember the model), 256 GB of SSD.

I would be really glad if someone helped me out on this!

post output from:
systemd-analyze
systemd-analyze blame

1 Like

systemd-analyze blame  :heavy_check_mark:
21.864s plymouth-quit-wait.service
1.402s systemd-random-seed.service
1.022s systemd-rfkill.service
707ms dev-sda1.device
516ms snapd.service
435ms systemd-backlight@backlight:intel_backlight.service
312ms ModemManager.service
282ms accounts-daemon.service
263ms ldconfig.service
231ms systemd-journal-flush.service
220ms user@1000.service
168ms systemd-udev-trigger.service
145ms udisks2.service
141ms systemd-logind.service
126ms systemd-tmpfiles-setup.service
101ms systemd-timesyncd.service
96ms systemd-udevd.service
90ms polkit.service
87ms systemd-modules-load.service
85ms bluetooth.service
79ms dbus.service
79ms upower.service
78ms NetworkManager.service
76ms lvm2-monitor.service
75ms systemd-tmpfiles-clean.service
71ms cups.service
68ms systemd-journald.service
63ms power-profiles-daemon.service
62ms snapd.apparmor.service
59ms systemd-vconsole-setup.service
56ms colord.service
45ms systemd-sysusers.service
40ms systemd-tmpfiles-setup-dev.service
34ms systemd-backlight@leds:dell::kbd_backlight.service
33ms gdm.service
33ms modprobe@fuse.service
29ms pamac-daemon.service
27ms systemd-journal-catalog-update.service
26ms plymouth-start.service
26ms plymouth-start.service
26ms plymouth-start.service
26ms systemd-update-utmp.service
20ms systemd-remount-fs.service
18ms plymouth-read-write.service
17ms dev-hugepages.mount
16ms dev-mqueue.mount
15ms sys-kernel-debug.mount
15ms sys-kernel-tracing.mount
15ms wpa_supplicant.service
14ms kmod-static-nodes.service
13ms dev-disk-by\x2duuid-b17c873e\x2d00c5\x2d47b8\x2da615\x2d1fe0b92f0423.sw>
13ms ufw.service
13ms modprobe@configfs.service
12ms systemd-update-done.service
12ms modprobe@drm.service
9ms systemd-sysctl.service
8ms tmp.mount
8ms rtkit-daemon.service
7ms systemd-user-sessions.service
6ms user-runtime-dir@1000.service
5ms alsa-restore.service
4ms sys-kernel-config.mount
4ms snapd.socket
3ms sys-fs-fuse-connections.mount
lines 40-62/62 (END)

Welcome to the forum! :wave:

Please edit your reply to use proper formatting:

this is the issue:
21.864s plymouth-quit-wait.service

Can you help me fix it? Should I mask it?

yes mask the plymouth services

I did. Only reduced a second. Still takes around 20 seconds…

maybe try this again did it change?

did you reboot after you masked the plymouth services?
if no then reboot and check again:

No, that’s not how it works. See Plymouth - ArchWiki

Then what should I be doing?

Yes, I rebooted and then tried again :frowning:

You can also disable and mask some services, which are not need normally.
1.lvm
2.modem manager
3.bluetooth

Read. Understand. Then do.

I believe this is for you.

Also see:

1 Like

This is my boot time, any way to improve it?

systemd-analyze                                                                                                                                                                                                  ✔  21m 37s  
Startup finished in 4.615s (firmware) + 27.253s (loader) + 10.156s (kernel) + 3min 44.749s (userspace) = 4min 26.774s 
graphical.target reached after 3min 44.748s in userspace.
    ~  systemd-blame                                                                                                                                                                                                                ✔ 
zsh: command not found: systemd-blame
    ~  systemd-analyze blame                                                                                                                                                                                                    127 ✘ 
3min 42.994s pacman-init.service
1min 14.850s mhwd-live.service
1min 10.279s manjaro-live.service
 1min 5.175s mirrors-live.service
      1.090s polkit.service
      1.089s NetworkManager.service
      1.012s dev-sdb.device
       871ms dbus.service
       865ms systemd-logind.service
       775ms ModemManager.service
       719ms udisks2.service
       621ms lvm2-monitor.service
       488ms dev-loop2.device
       463ms bluetooth.service
       451ms dev-loop0.device
       443ms dev-loop3.device
       437ms dev-loop1.device
       413ms systemd-tmpfiles-setup.service
       327ms systemd-rfkill.service
       190ms systemd-udev-trigger.service
       173ms user@1000.service
       161ms upower.service
       135ms systemd-tmpfiles-setup-dev.service
       114ms systemd-update-utmp.service
       111ms systemd-modules-load.service
        99ms wpa_supplicant.service
        87ms dev-hugepages.mount
        87ms dev-mqueue.mount
        86ms sys-kernel-debug.mount
        85ms sys-kernel-tracing.mount
        80ms systemd-journald.service
        79ms tmp.mount
        78ms kmod-static-nodes.service
        75ms modprobe@configfs.service
        74ms modprobe@drm.service
        73ms modprobe@fuse.service
        63ms systemd-udevd.service
        62ms packagekit.service
        55ms sys-fs-fuse-connections.mount
        54ms systemd-remount-fs.service
        54ms sys-kernel-config.mount
        38ms systemd-sysctl.service
        35ms systemd-backlight@backlight:intel_backlight.service
        31ms systemd-tmpfiles-clean.service
        23ms NetworkManager-wait-online.service
        21ms rtkit-daemon.service
        17ms systemd-journal-flush.service
        15ms systemd-random-seed.service
        11ms user-runtime-dir@1000.service
         7ms alsa-restore.service
         6ms etc-pacman.d-gnupg.mount
         5ms systemd-user-sessions.service

gods in heaven haha … you are in live usb session …