Faceswap installation or good alternatives

Hi all guys,

I discovered a beautiful program made with artificial intelligence that I would like to have.

I had it on my old system that I recently formatted, and I’d like to install it on my brand new Manjaro, does anyone want to show me how to do it here directly from Manjaro files? At least, for most files, as I think the faceswap program should be downloaded from Github.

Anyway, I’ve been told to avoid installing programs that are outside of the repo I have of defoult and AUR, how can you do that in this case?

PS if I remember correctly the procedure included:

  1. Install the proprietary drivers, I just installed the dolls.
  2. install conda.
    3.Phython 3.8
  3. download and install faceswap
  4. have fun

EDIT: First follow the link that you find in the first answer I received, secondly if you have a problem with opening anaconda-navigator look below on how to update it and solve the problem, as soon as you open the navigator configure it as in the guide of the first link, if it does not correspond work (which is likely) install cuda from your repo and then the right nvidia drivers as well (this will be done automatically as you install cuda).
I got this far, I don’t know if there is anything else to do, I find out step by step, I am currently downloading about 2.5 gigabite of data to install cuda, I hope it works, if there are other important things you need to know I’ll insert them here , if instead they are intuitive things, I will leave you the pleasure of intuiting them. Have a good time. Thanks to chomsky for the support. If you have any problems starting faceswap follow this link. It should all work. Error in extract - ModuleNotFoundError: No module named 'pynvml' - Faceswap Forum - The place to discuss Faceswap and Deepfakes

You can find the install procedure here:

Thanks, I’ll try.

I think this program don’t work on system Arch based, here i not see any mentioning about

Linux Most Ubuntu/Debian or CentOS based Linux distributions will work

@chomsky As I thought it might not work because Manjaro is not allowed to use anaconda, or a particular anaconda-navigator.

Do you think there could be some solution by continuing to use Manjaro?

Alternatively, somewhere I read that if something is wrong, and we wanted to have it or fix it as Manjaro users we could ask the developers to do it directly, do you know if any of them hang out here on the site or how to contact them?

Maybe it might be of interest to many people to use anaconda on their computer.

    if DISTRO_NAME in ['ubuntu', 'debian']:
UnboundLocalError: local variable 'DISTRO_NAME' referenced before assignment

Ok don’t worry I fixed it, just give this command in the terminal to correct the error:

conda update anaconda-navigator

PS. When a post is solved and the procedure is working, should you write in the first post “solved” or here you don’t need to do it?

Just mark the answer that helped you out most as the solution if there is one or edit your own post and explain how you did it.

Ok grabbed, thanks a lot for your help

I stopped here, I can not go on even with the guides that I find online.
The other problem is that when this happens, the program below displays the message error 1 about extract.py

2020-11-12 04:46:28,773 - WARNING linux_scaling.get_scaling_factor_using_dbus:27
An exception occurred during fetching list of system display settings.

2020-11-12 04:47:02,821 - ERROR download_api._download:265
'NoneType' object has no attribute 'get'

2020-11-12 04:47:08,192 - ERROR community.load_content:203
('/home/utent/.anaconda/navigator/content/videos.json', JSONDecodeError('Expecting value: line 1 column 1 (char 0)'))

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.