F11 and F12 don't work

I feel like I shouldn’t need to open this thread, because I see that there have been some in the past about this topic.

I somehow can’t find helpful info for my case in them though.

I think since a major update in the last days/weeks they started not responding. Can someone point me in the right direction?

you can use sudo showkey in a terminal or install xorg-xev https://man.archlinux.org/man/xev.1.en

pointing left for the next video. don’t forget to mark the bell and subscribe to the channel …

What those keys do depends on the desktop environment you’re running, and on how you defined those keys there.

Maybe you accidentally changed your type of keyboard in the settings? (Some keyboards have only 10 function keys.) Maybe your locale is wrong?

The bottom line is that we can’t possibly know what you have (or have not) done. Only you will know that — hopefully, at least. :man_shrugging:

I know that I didn’t change anything, but that it changed after an update.

And now I see the point you guys are making! :face_with_peeking_eye:

I’m trying to wrap my head around this, so here are some infos, that hopefully make sense.

  • Firstly of all basic settings seem to make sense:
localectl status                                                                     127 ✘ 
System Locale: LANG=de_DE.UTF-8
    VC Keymap: de
   X11 Layout: de

  • Secondly some more detailed info:
setxkbmap -print -verbose 10                                     ✔ 
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     de,de,cz,de
variant:    ,ru,,
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwertz)
types:      complete
compat:     complete
symbols:    pc+de+de(ru):2+cz:3+de:4+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+de+de(ru):2+cz:3+de:4+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};

  • Thirdly showkey does not register anything from F11 or F12 (neither from Fn + F11 or F12)

As a reminder, I didn’t change any settings, it happened after installing updates from the package manager.