Extremely slow WiFi

I’m basically on a fresh install of Manjaro KDE as far as network goes (haven’t touched anything concerning network configs). On fast[.]com I get a download speed of 35 Mbps (~4.3 mb/s) but if I actually try to download anything, the download speed gets super low (tested just now and I got 48.6KB/s from wget). Internet doesn’t disconnect and worked fine on my previous install of Windows (now wiped) and on my other devices.

inxi -F | grep iwlwifi

  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi

sudo dmesg | grep iwlwifi

[    3.254266] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    3.263184] iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
[    3.263196] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version:
[    3.263500] iwlwifi 0000:00:14.3: loaded firmware version 72.daa05125.0 so-a0-hr-b0-72.ucode op_mode iwlmvm
[    3.437673] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x430
[    3.550376] iwlwifi 0000:00:14.3: Detected RF HR B3, rfid=0x10a100
[    3.616163] iwlwifi 0000:00:14.3: base HW address: d4:54:8b:6a:d8:30
[    3.632075] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
[ 6430.649353] iwlwifi 0000:00:14.3: Unhandled alg: 0x703
[ 6430.675052] iwlwifi 0000:00:14.3: Unhandled alg: 0x703
[11126.041025] iwlwifi 0000:00:14.3: Unhandled alg: 0x703

Have a look here:

Has no impact on modern iwlwifi module.

This is disabled by default. And power management is handled by a different module - iwlmvm.

This is pretty extreme. If one of these options is desirable it is usually 11n_disable=8, which in fact does not disable N but rather enables antenna aggregation.

So really, especially to begin, I would suggest instead:


options iwlwifi 11n_disable=8 # enable antenna aggregation

If there are still issues … then it may be worth setting one of the options in iwlmvm:

power_scheme:power management scheme: 1-active, 2-balanced, 3-low power, default: 2 (int)

And if there are still issues … then maybe we can test disabling one or more of the modern standards.


This seems to have worked for me, I’ll monitor it for a few days and mark this as the solution if all is still well. Thanks!

I cant edit the above post. But for future wanderers…
swcrypto does exist again as an option for the iwlwifi module.

The older sw_crypto is still deprecated.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.