Extremely Low FPS on CSGO *No Apparent Reason* | Manjaro

I JUST switched to Manjaro and am pretty much experiencing Linux overall for the first time. As someone that’s used Windows for my entire life I am super confused by all the problems that come up with Manjaro non stop anyways that’s besides the point.

I downloaded CS:GO from steam of course and upon running it I got extremely bad frames like im talking about like 10-20fps.

Hmm ok maybe I got my resolution in the game cranked up maybe my video settings are ultra or something like that… Nope after changing EVERYTHING in the games options including resolutions to low. (Like i even went as far as to go 4:3 1024x768) and I was still getting 20 frames in the main menu alone. 20 FPS MAIN MENU

As I mentioned, I used windows as a main OS so playing CS:GO on windows gets me anywhere between 80-120fps in a Comp match and 60fps in a Community server (Of course this is with some of my graphics being turned up a bit but that only adds to my point here)

System Specs:
GTX 750ti
AMD Athlon X4 860k
12gb DDR3 Ram

Of course while my specs aren’t considered good in today’s age a game like CSGO can run fabulously on windows. Please let me know what other info I can post to help you guys out with helping me.

Side note: I figured I would add this last bit in, while I am new to Linux and wouldn’t know how to diagnose a problem like this I’m guessing something is limiting my GPU possibly CPU too, for example even tho I’ll have like 4k 60hz or 1440p 60hz on something as basic as scrolling down a forum page I really notice how it’s not smooth, and no I am certain I have 60hz as dragging a terminal window around or something is perfectly smooth.

Edit: Fixed spelling mistake

Hello @ObeyyRob :wink:

Did you install the nvidia drivers? The open source driver nouveau in general does not clock up, and stays at low clock due the lack of power management…

Check which driver you are running. Open a terminal and type:

inxi -Gazy


I appreciate reply! Alright after typing that in a terminal this is what I got

  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: eVga.com. 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1380 class-ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.6x15.0") 
  s-diag: 775mm (30.5") 
  Monitor-1: HDMI-1 res: 2560x1440 hz: 60 dpi: 107 
  size: 608x345mm (23.9x13.6") diag: 699mm (27.5") 
  OpenGL: renderer: NV117 v: 4.3 Mesa 20.3.4 direct render: Yes

And there we have it… you will need the proprietary driver from nvidia.

Installing it from command-line:

sudo mhwd -a pci nonfree 0300

or use the GUI. Somewhere in Settings in KDE you can install it. idk where.


1 Like

Ok well after putting that in the terminal I got this

> Using config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:1380) Display controller nVidia Corporation GM107 [GeForce GTX 750 Ti]
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
error: target not found: linux56-nvidia
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
Error: pacman failed!
Error: script failed!

I tried rebooting and reinstalling mhwd but I still get the same response. I may just be making a super beginner mistake here haha, I’ll keep trying.

That is because you installed Manjaro from a really old ISO Image. linux56 does not exist anymore. Switch to an LTS one. Just saying… linux510 and above will have problem with nvidia drivers. Just stay on LTS linux54 and you should be save with nvidia drivers.

sudo mhwd-kernel -i linux54

Then reboot and choose linux54 at grub bootloader. Now you can remove kernel 5.6:

sudo mhwd-kernel -r linux56

if not possible, then remove it like this:

pamac remove --unneeded linux56


sudo update-grub

Now you should be able to install the nvidia drivers.

And overall keep sure, your system is updated:

pamac upgrade

It is a rolling release: partial update = broken system.

Ok well it took me a minute to figure out how to get into this grub bootloader but I’ve done it and went into 5.4 did all of this and am now downloading the proprietary drivers.

Side note yea I totally forgot about the fact that installing manjaro from like a year old USB would probably be outdated haha

Will be back to mark it as a solution if everything checks out and if not I’ll make another reply here

While originally not planning on replying again I felt that I needed to.

Thank you so much you have fixed not only my frames issue but a side issue of where I couldnt do 4k 60hz

I was planning on leaving that issue for tommorow but updating my proprietary drivers fixed that too!
Everythings great except one thing that I will troubleshoot and may be able to fix, when I boot up CS:GO its all purple with the brightness up and green with it down. Hard to explain but I may be able to resolve this one on my own anyways thanks for helping me with my issue!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.