Extremely long boot time and can't get to graphical session after update


M laptop has become next to unusable after the latest update (I’m on stable branch). It takes at least 15 minutes to boot and all I can do is log into a tty.

Here is how it happens : First I get this message (which has always shown up while booting) on a black screen:

[FAILED] Failed to start Load/save *ness of backlight:amdgpu_b10

And after a while, a mouse cursor shows up, but sddm doesn’t load. From here I tried to get to a tty, which worked, although it takes a few minutes as well.

I tried this solution but only firefox and inxi were updated, and startx takes like 5 minutes to load a black screen, and then the tty comes back.

Since I’m posting this from another machine (which runs void btw) I can only provide this info from another topic:

  ~ $ inxi -SMCE 
  Host: ZaManjaro Kernel: 5.10.136-1-MANJARO arch: x86_64 bits: 64 
    Desktop: bspwm v: 0.9.10 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X570ZD_R570ZD 
    v: 1.0 serial: <superuser required> 
  Mobo: ASUSTeK model: X570ZD v: 1.0 serial: <superuser required> 
    UEFI: American Megatrends v: X570ZD.310 date: 07/04/2019 
  Info: quad core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 
    bits: 64 type: MT MCP cache: L2: 2 MiB 
  Speed (MHz): avg: 1487 min/max: 1600/2000 cores: 1: 1457 2: 1558 3: 1368 
    4: 1698 5: 1502 6: 1357 7: 1554 8: 1403 
  Device-1: IMC Networks type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends

Does anyone know how to fix this ?
Thank you
(I guess I should start using Timeshift…)

Not without some more investigation.

Easiest would be to get a hold of an ISO with an LTS kernel, write it to a thumb drive, boot from it, and enter as chroot environment. From there, logs can be inspected, or retrieved, copied, and provided here.

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

From the chroot environment run the following:

journalctl --boot --priority=3 --no-pager

This will output all Warnings and Errors encountered during the boot process.

Thank you for replying,

I’m curently chrooting from the iso and here is the output from journalctl:

[manjaro /]# journalctl --boot --priority=3 --no-pager
An error was encountered while opening journal file or directory /var/log/journal/97a2d302b11d42f6a37c347056af4507/system@34c5400cc573439c85542e07cc43050a-0000000000000001-0005e1a7d9fba49e.journal, ignoring file: Structure needs cleaning
-- No entries --

I tried to cat the .journal file, it returned cat: /var/log/journal/97a2d302b11d42f6a37c347056af4507/system@34c5400cc573439c85542e07cc43050a-0000000000000001-0005e1a7d9fba49e.journal: Structure needs cleaning

According to this page:

That is strongly indicative of file-system corruption. You should unmount, make a sector-level backup of your disk, and then run e2fsck to see what is up. If there is major corruption, you may later be happy that you did a sector-level backup before letting e2fsck tamper with the data.

And this is where I tell you that I’m not sure where to go from here. Except, I think the Sector-level backup can be done with dd:

dd bs=5M if=/dev/<sdX> of=/path/to/space.img


  • if is the device you’re backing up. Say for instance it’s sdy, then it would be /dev/sdy;
  • of if the location where you’re making the backup to. Ensure that this location has ±110% of the drive you’re doing the backup of worth of free space.

Do I have to back up the whole device or only a partition (sda1/sda2) ? Also do I have to output it to an external drive ? Because it sounds like it will copy the whole disk which in my case is about 500GB

  1. The whole drive yes. So, I’m guessing to a ±600GB or bigger. (But that might be just me, I like wiggling room.)
  2. Not just a partition, no. The complete disk. (i.e.: /dev/sda and not just /dev/sda1)

And to restore it, I’ll simply have to invert if and of right ?

Correct. But ALWAYS be careful with dd. As you can see, it can easily cause problems.

Ddrescue is available on manjaro’s repo and ddrescue-gui is available on aur.

I’ve never used ddrescue or ddrescue-gui so don’t know anything about them.

Before I go forward I wanna make sure of one thing:

So I ran dd if=/dev/sda of=back.img status='progress' bs=5M from my $HOME which is in sda. I expected it to copy ~190GB of data because this was the used space in my hard drive, but in the end it copied until the drive was full (I stopped it shortly before), so I’m wondering: did it copy empty space or did it start copy the backup file into the backup file, since it is part of sda ? (I had no other choice than this since I don’t have any external drive big enough)

You tried to copy the whole sda to $HOME on sda? No, that won’t work. It needs to be on a different drive.

Well, I cannot do this, unless there is a way to copy to the internal drive of another machine with something like rsync (I have no idea if that’s even possible) or through ssh

You should be able to mount the other macine with sshfs and then do of=/path/to/mount/hdd.img and just set bs=2M in the command then…or that’s the theory anyways…

I tried it with a 150MB file, it works but it super slow, less than 500KB/s, which would take days to transfert 200GB ><

Then try and get another HDD. That’s all I can recommend then.

I gonna do this, I’ll come back to report how e2fsck will perform, thanks for your support


Out of curiosity I tried to boot my machine with another kernel (5.4) and it booted fine (I’m writing this post from it), so I guess the update from 5 days ago didn’t download the latest kernel correctly. I’ll launch today’s update and see how it goes

Problem solved, yesterday’s update didn’t fix 5.10 kernel so I simply removed it and installed 5.15 instead.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.