Extreme lag in some apps after sometime

I recently (been about a couple weeks, I think) upgraded my Manjaro kernel to 5.4.89-1-MANJARO. Everything has been working great.

Until recently, a couple days ago, when for some reason after a few hours of uptime some apps become very unresponsive. Entering text takes 3-4 seconds, scrolling is very laggy, context menu take a few seconds to appear. Only a few handful of apps that I use are affected my this Firefox, quasselclient (Qt), keepassxc. Other apps like chromium, emacs, Krita, gnome-terminal work as usual.

I tried the scientific method to find what could have caused this but nothing worked. The only two things that come to mind are, that I installed KDE plasma recently, and did a sudo pacman -Syu. However, I have uninstalled all packages associated with plasma but I’m not sure if it added some config which is doing this.

I tried looking into the logs and nothing there is nothing odd in them.

My system config:

$ inxi -Fza                                                                                                                   130 ↵
System:    Kernel: 5.4.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/vmlinuz-5.4-x86_64 root=UUID=71dc1cde-549e-4ed3-8adb-3e29c03cdd07 rw quiet 
           resume=/dev/mapper/luks-0c587585-2660-456d-8724-a70d44395ca5 resume=UUID=3502c696-f712-4761-8dec-c3961ac8a191 
           mem_sleep_default=deep usbhid.quirks=0x04d9:0xa293:0x00000400 
           Desktop: i3 4.19 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0D0T05 v: A00 serial: <filter> UEFI: Dell v: 1.17.1 date: 07/09/2020 
Battery:   ID-1: BAT0 charge: 78.9 Wh condition: 78.9/97.0 Wh (81%) volts: 12.7/11.4 model: SMP DELL GPM0365 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: DE L2 cache: 9 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 1850 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1850 2: 1706 3: 1287 4: 3069 5: 2778 6: 2019 7: 1704 
           8: 1765 9: 1855 10: 3731 11: 3609 12: 1905 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A alternate: nouveau, nvidia_drm, nvidia 
           bus ID: 01:00.0 chip ID: 10de:1c8c 
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-12:4 chip ID: 0c45:671d 
           Display: x11 server: X.Org 1.20.10 driver: loaded: intel display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.4.89-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Bigfoot Networks driver: ath10k_pci 
           v: kernel port: 3000 bus ID: 3b:00.0 chip ID: 168c:003e 
           IF: wlp59s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb bus ID: 1-4:2 chip ID: 0cf3:e300 
Drives:    Local Storage: total: 2.29 TiB used: 226.46 GiB (9.7%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KXG60ZNV512G NVMe 512GB size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 10604107 
           ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Western Digital model: WD My Passport 25E1 size: 1.82 TiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 1021 
Partition: ID-1: / raw size: 288.51 GiB size: 282.98 GiB (98.08%) used: 226.2 GiB (79.9%) fs: ext4 dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-0c587585-2660-456d-8724-a70d44395ca5 
           ID-2: /boot raw size: 270 MiB size: 253.4 MiB (93.86%) used: 163.7 MiB (64.6%) fs: ext4 dev: /dev/nvme0n1p7 
           maj-min: 259:7 
           ID-3: /boot/efi raw size: 200 MiB size: 196.9 MiB (98.45%) used: 18.1 MiB (9.2%) fs: vfat dev: /dev/nvme0n1p8 
           maj-min: 259:8 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 4 GiB used: 84.2 MiB (2.1%) priority: -2 dev: /dev/nvme0n1p9 maj-min: 259:9 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2515 fan-2: 2480 
Info:      Processes: 303 Uptime: 9h 26m wakeups: 1 Memory: 15.29 GiB used: 5.73 GiB (37.5%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1616 lib: 385 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.2.02 

Any idea what might be up, where I could at least find logs related to the problem?

I found the fix after number of downgrades of drivers. I had to add Option "DRI" "2"

To my /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
    Identifier  "Intel Graphics" 
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    Option      "DRI" "2"

PS: So far it is working great. It’s been six days since the last reboot due to this problem!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.