Extra screen setup (nvidia / intel)

Hi! I’ve been struggling with connecting an extra screen to my Acer Nitro 5 laptop for a while now… I have tried several tutorials and none have worked for me. I can leave the output to some commands that might be useful.

inxi -G

Graphics: Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 440.100
Device-3: Quanta HD User Facing type: USB driver: uvcvideo
Display: x11 server: XOrg 1.20.8 driver: modesetting,nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100


Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm

Here says HDMI-0 disconnected but I have a monitor connected (which I tested on windows and worked fine)

I also installed optimus-manager and switched to my Nvidia Gtx 1050 gpu, and it still doesnt work.

The hybrid drivers are not very good for multi-monitor setups, so have you tried the proprietary nVidia driver already?


Hello @Fabby, thanks for your reply!

For some reason I can’t upload a picture, but I checked the Hardware Configuration and under the nVidia gpu I have installed video-hybrid-intel-nvidia-440xx-prime and the same on the Intel one. Should I install the one that says video-nvidia-440xx? I think I tried pressing Auto Install Propietary Drivers and thats what I have.

That’s because you didn’t read enough before posting a question and then you get into Trust Level 0. TL1 and up can post pictures.

But you don’t need any pictures because: yes, that’s the only one you want. As this is dangerous¹ to do, please make a crash-proof backup first:


  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Remove all crud first:

    sudo mhwd --listinstalled
    sudo mhwd --remove pci EverySingleLineThatCameUpAbove
    pamac remove --no-save optimus-manager
  • Now you have no video drivers, so now we’re adding the correct one back in:

    sudo mhwd --install pci video-nvidia-440xx
    sudo reboot

That should have done it!


Thanks @Fabby, I did all of this but it still doesn’t work :frowning:
I checked doing this

And the output was only video-nvidia-440xx.

Should I remove optimus-manager? I still have it running with the default set on nVidia.

I’ve been reading a lot trying to figure this out. I found the following command:

mhwd-gpu --status

Which the output was warning: could not find '/etc/X11/xorg.conf.d/90-mhwd.conf'!
Then I remembered that when I installed optimus-manager, it said it would remove these files to avoid conflicts, maybe this is the problem now, I don’t have these files. Maybe someone who understands these better could help me, since I have no idea what to do next.

Urgh… :sob:


The mhwd program should have created that automatically,

so please remove optimus-manager , then remove the nvidia driver again, then add it again. (all using mhwd)

I finally did it, I removed the optimus-manager, and then saved the configuration file of nvidia-settings, that did the trick, thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.