External SSD (with Manjaro installed) failed to unmount before shutdown/restart

Hello guys,
I got a error message when i restart/shutdown my PC, that my SDD (Samsung Portable SSD T5)
are busy and won’t unmount for shutdown. I have a screenshot with the error message:

I have this error after the third reboot since i first time installed manjaro on my External SSD,
after 2-3minutes blackscreen this message showed up… now this error comes everytime but without any delay.

If you guys need any logs please let me know, but please explain me how to create this, because im still not into this linux stuff.

I hope you guys can help me out, thanks in advanced.

EDIT: Okay, here are my logs:

  • Mod-edit: Formatting
    Please don’t combine output of different commands, it makes them unnoticed.
> inxi -Fazy
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MONETARY = "de_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_TIME = "de_DE.UTF-8",
        LC_NUMERIC = "de_DE.UTF-8",
        LANG = "en_DE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/vmlinuz-5.9-x86_64 
  root=UUID=eb235aa7-d461-413d-800e-ea57385703fb rw quiet apparmor=1 
  security=apparmor resume=UUID=a44dd3c4-f5f1-4587-8934-6f7413d28d4f 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: Z170X-UD3 v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z170X-UD3-CF v: x.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F23d date: 12/01/2017 
CPU:
  Info: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: E2 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 64026 
  Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 801 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: Micro-Star MSI driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1e07 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 122 s-size: 533x302mm (21.0x11.9") s-diag: 613mm (24.1") 
  Monitor-1: DP-4 res: 2560x1440 dpi: 123 size: 527x296mm (20.7x11.7") diag: 604mm (23.8") 
  OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: NVIDIA TU102 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f7 
  Device-3: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series] driver: snd_hda_intel v: kernel bus ID: 0b:00.0 chip ID: 1102:0012 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 3.87 TiB used: 348.60 GiB (8.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B7QCXE7 scheme: GPT 
  ID-2: /dev/sda vendor: Samsung model: SSD 830 Series size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 3B1Q scheme: MBR 
  ID-3: /dev/sdb vendor: HGST (Hitachi) model: HDN724030ALE640 size: 2.73 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A5E0 scheme: GPT 
  ID-4: /dev/sdc type: USB vendor: Samsung model: Portable SSD T5 size: 465.76 GiB block size: physical: 512 B logical: 512 B serial: <filter> scheme: MBR 
Partition:
  ID-1: / raw size: 88.61 GiB size: 86.72 GiB (97.87%) used: 14.50 GiB (16.7%) fs: ext4 dev: /dev/sdc1 
  ID-2: /boot raw size: 200.0 MiB size: 189.7 MiB (94.84%) used: 150.8 MiB (79.5%) fs: ext3 dev: /dev/sdc3 
  ID-3: /home raw size: 332.03 GiB size: 325.82 GiB (98.13%) used: 3.01 GiB (0.9%) fs: ext4 dev: /dev/sdc4 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 2.93 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdc2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 36 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25% 
Info:
  Processes: 207 Uptime: 42m Memory: 15.59 GiB used: 1.34 GiB (8.6%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1235 lib: 339 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08
> journalctl -x -p3 -b1
-- Logs begin at Thu 2020-08-06 04:21:30 CEST, end at Tue 2020-12-29 10:49:52 CET. --
Aug 06 04:37:24 koboldx-z170 kernel: watchdog: watchdog0: watchdog did not stop!
> sudo fdisk -x
Disk /dev/nvme0n1: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 960 EVO 500GB               
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: F6C31B20-AEE8-03A6-C8C6-B03DBAABE900
First LBA: 34
Last LBA: 976773134
Alternative LBA: 976773167
Partition entries LBA: 2
Allocated partition entries: 128

Device         Start       End   Sectors Type-UUID                            UUID                                 Name Attrs
/dev/nvme0n1p1  2048 927928319 927926272 EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 7B64E8F0-5774-01D3-7874-B23DBAABE900 Basic data partition

Disk /dev/sda: 238.47 GiB, 256060514304 bytes, 500118192 sectors
Disk model: SAMSUNG SSD 830 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xe9182337

Device     Boot Start       End   Sectors Id Type            Start-C/H/S   End-C/H/S Attrs
/dev/sda1  *     2048 442370047 442368000  7 HPFS/NTFS/exFAT     0/32/33 1023/254/63    80


Disk /dev/sdb: 2.73 TiB, 3000592982016 bytes, 5860533168 sectors
Disk model: HGST HDN724030AL
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 1A6D9890-4635-4233-8C71-89052C9C1DC7
First LBA: 34
Last LBA: 5860533134
Alternative LBA: 5860533167
Partition entries LBA: 2
Allocated partition entries: 128

Device          Start        End    Sectors Type-UUID                            UUID                                 Name Attrs
/dev/sdb1          34     262177     262144 E3C9E316-0B5C-4DB8-817D-F92DF00215AE E633B49C-B3E5-444F-A4CA-F449990F028D Microsoft reserved partition
/dev/sdb2      264192 1229064191 1228800000 EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 185BB421-937B-4EB9-AA63-F3414F53962F Basic data partition
/dev/sdb3  1229064192 3543304191 2314240000 EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 648502F4-0F0D-415D-A33F-7CE22DF69496 Basic data partition
                                                                                                                           GUID:63
/dev/sdb4  3543304192 5860530175 2317225984 EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 8BAE0754-2B94-47ED-BC81-8CC64C661848 Basic data partition
                                                                                                                           GUID:63
Partition 1 does not start on physical sector boundary.


Disk /dev/sdc: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Portable SSD T5 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 33553920 bytes
Disklabel type: dos
Disk identifier: 0xa08ac34c

Device     Boot     Start       End   Sectors Id Type                 Start-C/H/S  End-C/H/S Attrs
/dev/sdc1          411648 186238975 185827328 83 Linux                   25/159/7 328/214/14 
/dev/sdc2       186238976 192382975   6144000 82 Linux swap / Solaris    433/89/1  426/131/2 
/dev/sdc3            2048    411647    409600 83 Linux                    0/32/33   25/159/6 
/dev/sdc4       192382976 888702975 696320000 83 Linux                   711/73/3   23/51/28 

Partition table entries are not in disk order.

There are many ways to install, so start by explaining in details how you installed it and what medium you used, it might be related or not…

Installed the (non-Minimal ISO) per USB Livestick (MBR) normal way (no Architect) but with manual partition
200MB EXT3 (Boot)
88GB EXT4 (Root)
332GB EXT4 (Home)
3GB (Swap)

Just as i said, the first 3 times i could restart Manjaro without a problem… I remember i just deactivated some services but nothing seriously, the closest was Removeable Device Automounter.

But as far i rember, that was after i had this error already.

Seeing you mentioned that you used MBR more info on your hardware could also help others to help you better:

At first sight one would think what does hardware have to do with an error about failed un-mounting, but you never know.
Providing more info as what is needed can only help others to help you more :wink:

PS:
I just noticed from your Screenshots, that those were taken from within M$ :thinking:
Are you using a VM to boot your Manjaro?

1 Like

:notebook:Mod-edit: Formatting
Please correct if i placed info out-of-line, i just replaced the | with a newline…

Skylake i7-6700K@4700 MHz
Gigabyte-Z170X-UD3
16GB DDR4 G.Skill 2800MHz
MSI 2080Ti Ventus OC
SDD Samsung 830(256 GB)
NVMe Samsung 960 Evo(512GB)
HDD HGST 3TB
Creative Soundblaster AE-5
Dell S2417DG(1440p 144Hz)
Rift CV1

Nope, its inside Linux Manjaro, no VM at all… only some layout tweaks, that it looks closer to Win7 :slight_smile:

You still see the difference in the taskbar where the manjaro settings manager is shown up.

I have no other HDD’s or SSD’s activated with Linux. Any more info required?

And my Samsung T5 External USB Device is pretty new and its still doing a stable job with my first manjaro install since 3 month, i had only 1 blackscreen, but that was related to Shotcut i think.

My 200MB Bootpartition is already used with 150MB. Could this cause maybe a problem.

It would have helped more if you used the output of the commands in the link i gave, which include vendor:device ID’s etc…

A complete list of all your storage devices would have been better, eg: sudo fdisk -x

But anyhow hope it will be enough for those that will help :wink:

1 Like

Added the Logs to the first Post.

Looks like this bug is not rare, but still no fix… that’s really sad :frowning: