External screen not longer recognized

Hello everyone! I finally stumbled upon an issue I can’t seem to solve by myself. Since yesterday my external screen is no longer being recognized. Brief history:

  • A few days ago I performed a fresh installation (manjaro-kde-24.0-minimal-240513-linux69.iso) and everything worked like a charm.
  • Yesterday morning I plugged in my external screen as usual and suddenly it stays black.
  • Troubleshooting, including
    • Searching for similar topics: lots of results but related to NVIDIA which doesn’t apply to my system.
    • Switching to Kernel 6.6 LTS, re-installing graphic related packages and countless reboots: didn’t solve the issue.
    • Booting live system from USB: works like a charm so it’s not a hardware issue (screen, cables, HDMI to USB-C adapter).
    • I finally decided to re-install from scratch and everything worked like a charm…
  • …until this morning when I opened my laptop, plugged in the external screen and noticed once again that nothing happens.

I’m at loss here; there’s nothing fancy going on with my setup, my config is minimal, and everything graphics-related is out-of-the-box.

$ inxi -G
Graphics:
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1: N/A 2: 1920x1200~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.6-manjaro1.1
    renderer: Mesa Intel Graphics (ADL GT2)
  API: Vulkan Message: No Vulkan data available.
$ mhwd -l
0000:00:02.0 (0300:8086:46a6) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
$ mhwd-kernel -li
mhwd-kernel -li                                                                                ✔ 
Currently running: 6.9.0-1-MANJARO (linux69)
The following kernels are installed in your system:
   * linux69

Please let me know what else I can provide!

//Edit: This is what happens when I plug in my external screen:

$ journalctl --since "2024-05-22 09:20:00" --until=now

Looks like it is USB related and not graphics related? Will keep investigating but I’m grateful for input!

//Edit 2: Not sure if helpful:

$ mhwd -li                                                                                       ✔ 
Warning: No installed PCI configs!
Warning: No installed USB configs!

Also I I have other USB devices connected and they are working.

//Edit 3: xrandr --auto enables the external display but it’s mirroring the laptop screen. External does not show up in display settings. I keep working from there…

//Edit 4: I can make it work temporarily by manually configuring both displays with xrandr --output. After that both show up in the device settings. However this does not persist, after reboot I have to repeat this.

If someone has an idea as to why this happened (despite working well first) and how to solve it permanently I’d greatly appreciate that.

I only have ideas - thoughts …

I suspect the issue is caused by power or perhaps more correct lack thereof.

The USB-c to HDMI adapter may not get enough juice - yes I am aware that it worked until yesterday - that puzzles me too.

Does the connector have an additionional input - possibly supplying extra juice?

That suggests the HDMI is not recognized for what it is - due to USB connection.

You tagged with x11 - so a valid question is - how is wayland doing in detecting the HDMI ?

Depending on the connector and the connection - is it possibly that you need to rotate the USB C 180 degrees ?

1 Like

Thanks for your reply! Unfortunately not, it’s a dead simple one. Looks like I found another reason to get a proper dock other than a more organised desk. That one would provide 95W with my device only needing 59W.

//Edit; Just saw your edit - testing this now!

//Edit 2: Flipping USB around didn’t change anything. Switching to Wayland did indeed work. I tried Wayland first but due to some other issues I went back to X11 for now. Does this help to figure out how to fix it on X11?

Not really - but it confirms the device work as intended.

The fact that you can activate the device using xrandr also work in favor of the device.

I am a bit puzzled about the fact that it works with the live ISO - but not the installed system.

Since it is Iris Xe gpu - I am speculating in arguments for the i915 driver on the kernel command line - same as used on the ISO

i195.modeset=1

But as your initial topic list the driver as modesetting - it is a guess

Could you please provide the full output from

inxi -F
1 Like

Here we go

I am a bit puzzled about the fact that it works with the live ISO - but not the installed system.

Is it possible something got moved over from live to install temporarily and got lost at first reboot or something? Although I’m 90% sure I didn’t reboot between reinstall yesterday and this morning.

The ISO enables modesetting and the hardware is configured by mhwd after install and therefore the i915.modeset=1 is not carried on to the installation.

There has been varios topics which has seen a solution by adding configuration arguments for the i915 driver.

From what I understood while confguring a laptop with a i7-13700H there is various arguments to adjust the behaviour of Iris Xe - I don’t know what makes your system purr - it appears to be different depending on the vendor of the system.

https://forum.manjaro.org/search?q=i915.enable%20order%3Alatest

I would check mkinitcpio.conf

The HOOKS array should contain kms after modconf
The MODULES array may benefit from adding i915

Rebuild after saving the file

 sudo mkinitcpio -P
 sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

For some reason the issue didn’t occur the past two days. Nothing else has changed; I could live with configuring the screens manually every morning until I get a proper dock with more power and direct HDMI but at the moment I don’t even have to.

I can’t say I understand what’s going on here but if it happens again even with the dock I will continue investigating with your latest suggestion.

Anyways, I appreciate you took the time and effort to help me solve this issue. Mange tak!

1 Like

I am thinking - just an idea for next time - the contacts inside the hdmi male connector - just a thought - next time - try to apply a slight pressure on both sides of the hdmi male connector - using your fingers - before you connect the adapter with the monitor - if this works it is a worn cable - perhaps a worn adapter.

It is a trick I sometimes use with USB cables - just a tiny press causing the connection points to get a iota closer to the connector.

1 Like