External Mouse keeps Thinkpad awake

Hey guys,

I’ve using Manjaro KDE on a Thinkpad Yoga L13 since the beginning of this year and enjoy using it so far. I’ve encountered a

strange behavior with my mousepad

I opened a thread for that issue in the apparently outdated manjaro forum. I can’t find the link to it since like many links from e.g. google it ends in “topic not found”. Long story short, my touchpad is too sensitive to use properly. I registers a click at a pressure where it should just move the pointer around. I someone wants to collaborate on that issue feel free to say something and I open a new thread.

and therefore I’m currently using an external mouse. I’ve noticed that although my laptop hibernates correctly when I close the lid it seems to be awake when I open the lid again. I found out that’s definitely connected to the mouse usage since this does not happen when I disconnect or turn of the mouse before closing the lid.
Can somebody help me to fix that and point me to the right direction what’s going wrong here?

Many thanks and best regards

Welcome to the forum! :slight_smile:

I’m afraid I cannot help you with that issue, but maybe somebody else can.

This is indeed due to the mouse itself. Some computer mice are hypersensitive and register the slightest vibration ─ e.g. from a truck driving by on the road ─ as a mouse displacement, and then the screen ─ or in your case, the computer ─ wakes up again.

I am using a Logitech wireless mouse on a desktop machine, and it has the same problem when the monitor is in standby. I’ve also seen it with my previous mouse, which was wired, but it was also a Logitech.

I’ve also been told that the risk of this happening is higher when the mouse is connected via USB than when it’s connected to a PS/2 port, but I cannot corroborate that, as I’ve had it happen with that (same wired) Logitech connected via a PS/2 port as well. :man_shrugging:

1 Like

Thank you for your answer, appreciate it! :slightly_smiling_face:

I totally get where you’re coming from and agree with that. I even think for a desktop machine this is probably even a wanted behavior.
But for my laptop I want the “the lid is closed” state to be factor that determines the standby state. So I’m looking for a way to make my laptop ignore mouse input as long the lid is closed and therefore not to wake up. :neutral_face:

Well, the only two ways I see are…

  1. Disconnect the mouse before putting the laptop in standby; or

  2. Use a wireless mouse that switches itself off after a time of inactivity so as to spare its battery. That’s the reason I myself started using a wireless mouse in the first place.

1 Like

Yeah, I figured. Maybe another user knows another way. For me, it seems more of a general problem than the specific setup I’m using, but not sure.

That’s what I do now - at least if I remember… :man_facepalming:

Well I’m not sure, if my mouse does that or not. It a Cherry something something. :see_no_evil:
What mouse do you use, that has this function? And it stays turned off until you physically press a button or how does it work?

The one I’m using is a now already old Logitech MX-1000 laser mouse. Its battery is not removable but rechargeable. The receiver is what’s connected to the USB port on the back of the computer chassis, and it doubles as a charging station.

The mouse itself goes into standby after a few seconds, and pressing a button, moving the scroll wheel or moving the mouse wakes it up again. It also switches itself off when placed in the charging station ─ there’s a mechanical button at the bottom of the mouse that gets pressed when the mouse is put into the charging station, and it physically switches off the optical sensor.

There’s also a mechanical “on/off” slider at the bottom of the mouse, by the way.