External monitor not working on KDE

My external monitor stopped working after unplugging it. I can see the login prompt to start a session, but once I log in the KDE logo appears for a second and then it’s gone and the monitor won’t display anything. It has worked normally until now, and I’m not sure what causes the flaw. I didn’t update anything before or after this happened and the system is up-to-date. I tried both HDMI and USB-C (to HDMI dongle).

I found a post (“Monitor Stopped Working Suddenly – Displays at login, not after” – I don’t seem to be allowed to post the link) and changing users works, but I’d like to stay with the actual user if possible.

Any ideas on what may have caused the issue and how to fix it?

Thinkpad p53

inxi --full --admin --verbosity=7 --filter --no-host
System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=8ad4c5a0-a095-4ad0-9e56-f777755bfc33 rw 
           quiet udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20QNCTO1WW v: ThinkPad P53 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20QNCTO1WW v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N2NET37W (1.22 ) 
           date: 04/28/2020 
Battery:   ID-1: BAT0 charge: 80.8 Wh condition: 82.8/90.0 Wh (92%) volts: 12.7/11.2 model: Celxpert 5B10W13902 
           type: Li-poly serial: <filter> status: Unknown cycles: 26 
Memory:    RAM: total: 30.98 GiB used: 2.84 GiB (9.2%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 6-Core model: Intel Core i7-9850H bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: D (13) microcode: D6 L2 cache: 12.0 MiB bogomips: 62431 
           Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 
           bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
           dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
           hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce 
           md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb 
           pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep smx ss ssbd sse 
           sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort mitigation: TSX disabled 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3e9b 
           Device-2: NVIDIA TU106GLM [Quadro RTX 3000 Mobile / Max-Q] vendor: Lenovo driver: nvidia v: 440.100 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f36 
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo bus ID: 1-8:3 chip ID: 13d3:56bc 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting,nvidia display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 3840x1200 s-dpi: 96 s-size: 1014x317mm (39.9x12.5") s-diag: 1062mm (41.8") 
           Monitor-1: DP-1 res: 1920x1200 dpi: 89 size: 550x340mm (21.7x13.4") diag: 647mm (25.5") 
           Monitor-2: eDP-1-1 res: 1920x1080 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: Quadro RTX 3000/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: BEHRINGER type: USB driver: snd-usb-audio bus ID: 1-5.2:7 chip ID: 1397:0509 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15bb 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 bus ID: 52:00.0 chip ID: 8086:2723 
           IF: wlp82s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 953.87 GiB used: 215.06 GiB (22.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBQNTY-1T00-1001 size: 953.87 GiB 
           block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11130101 
           scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 452.84 GiB size: 444.74 GiB (98.21%) used: 215.03 GiB (48.4%) fs: ext4 
           dev: /dev/nvme0n1p5 label: N/A uuid: 8ad4c5a0-a095-4ad0-9e56-f777755bfc33 
           ID-2: /boot/efi raw size: 260.0 MiB size: 256.0 MiB (98.46%) used: 29.1 MiB (11.4%) fs: vfat 
           dev: /dev/nvme0n1p1 label: SYSTEM uuid: 844C-1034 
Swap:      Alert: No Swap data was found. 
Unmounted: ID-1: /dev/nvme0n1p2 size: 16.0 MiB fs: <superuser/root required> label: N/A uuid: N/A 
           ID-2: /dev/nvme0n1p3 size: 499.78 GiB fs: bitlocker label: N/A uuid: N/A 
           ID-3: /dev/nvme0n1p4 size: 1000.0 MiB fs: ntfs label: WinRE_DRV uuid: F6964F7E964F3E7D 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-5:2 info: Fresco Logic USB2.0 Hub ports: 5 rev: 2.1 speed: 480 Mb/s chip ID: 1d5c:5010 
           Hub: 1-5.1:5 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 05e3:0608 
           Device-1: 1-5.1.3:8 info: Logitech Marble Mouse (4-button) type: Mouse driver: hid-generic,usbhid 
           interfaces: 1 rev: 1.1 speed: 1.5 Mb/s chip ID: 046d:c408 
           Hub: 1-5.1.4:10 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 05e3:0608 
           Device-1: 1-5.1.4.1:11 info: Apple Aluminium Keyboard (ISO) type: Keyboard,HID driver: apple,usbhid 
           interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 05ac:0250 serial: <filter> 
           Device-2: 1-5.2:7 info: BEHRINGER type: Audio driver: snd-usb-audio interfaces: 6 rev: 2.0 
           speed: 480 Mb/s chip ID: 1397:0509 
           Device-3: 1-5.3:9 info: Fresco Logic type: Billboard driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s 
           chip ID: 1d5c:7102 
           Device-4: 1-8:3 info: IMC Networks Integrated Camera type: Video driver: uvcvideo interfaces: 4 
           rev: 2.0 speed: 480 Mb/s chip ID: 13d3:56bc serial: <filter> 
           Device-5: 1-9:4 info: Synaptics Prometheus MIS Touch Fingerprint Reader type: <vendor specific> 
           driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:00bd serial: <filter> 
           Device-6: 1-11:6 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card driver: N/A interfaces: 1 
           rev: 2.0 speed: 12 Mb/s chip ID: 058f:9540 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 6-2:2 info: Fresco Logic USB3.0 Hub ports: 4 rev: 3.0 speed: 5 Gb/s chip ID: 1d5c:5000 
Sensors:   System Temperatures: cpu: 56.0 C mobo: 43.0 C gpu: nvidia temp: 45 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 287 Uptime: 28m Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
           pacman: 1668 lib: 475 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

Follow-up:
I just tried XFCE and the external display works fine. So I guess it’s a KDE issue.

I tried renaming ~/.kde4 to ~/.kde4.old to restore KDE’s defaults but the issue persists and actually nothing changed in my desktop. Is plasma using a different directory? Should I back-up all ~/.config/plasma* and remove it?

Where does KDE store the info about displays? I guess xrandr is DE-agnostic.

Any suggestions on where to look?

I managed to make it work manually with

xrandr --output DP-1 --auto --left-of eDP-1-1

This seems to fix the problem permanently.