External monitor not detected over HDMI

Hello everyone,

I’m having Issues with my laptop (Lenovo Thinkbook 14 G2 ITL) not detecting external display connected over HDMI, I’ve already done quite a bit of research and tinkering on my own, with no luck. I suspect this issue is drived/kernel related, but can’t really pinpoint and fix the issue.

Here is my system configuration:

inxi --full --admin --verbosity=7 --filter --no-host

  Kernel: 5.19.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.19-x86_64
    root=UUID=0891cfcc-727f-4a2f-91ed-3f6dd2f191c1 rw quiet
    udev.log_priority=3 i915.fastboot=0
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 2 dm: 1: GDM v: 42.0 2: LightDM v: 1.30.0 note: stopped
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20VD v: ThinkBook 14 G2 ITL
    serial: <superuser required> Chassis: type: 10 v: ThinkBook 14 G2 ITL
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required>
    UEFI: LENOVO v: F8CN47WW(V2.10) date: 03/27/2022
  ID-1: BAT1 charge: 41.1 Wh (92.2%) condition: 44.6/45.0 Wh (99.1%)
    volts: 13.1 min: 11.6 model: LGC L19L3PDA type: Li-ion serial: <filter>
    status: charging cycles: 23
  RAM: total: 15.41 GiB used: 3.76 GiB (24.4%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake built: 2020 process: Intel 10nm family: 6
    model-id: 0x8C (140) stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1484 high: 2800 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1115 2: 658 3: 1158
    4: 938 5: 1222 6: 2800 7: 2800 8: 1183 bogomips: 44864
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand
    rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect
    ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 3-7:3
    chip-ID: 5986:212b class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: xfwm v: 4.16.1 driver: X: loaded: modesetting unloaded: vesa
    alternate: fbdev gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x14d4 built: 2016 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81")
    diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.2
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.19.0-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.21 running: no
  Sound Server-4: PulseAudio v: 16.1 running: yes
  Sound Server-5: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 0000:2b:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp43s0 state: down mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-85f28954-da50-47e9-877b-5dbf659a9bdf maj-min: 254:0
    type: LUKS dm: dm-0 size: 341.29 GiB
  p-1: nvme0n1p6 maj-min: 259:6 size: 341.3 GiB
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
  Local Storage: total: 476.94 GiB used: 28.65 GiB (6.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZALQ512HBLU-00BL2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 5L2QFXM7 temp: 41.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 341.29 GiB size: 334.87 GiB (98.12%)
    used: 28.64 GiB (8.6%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-85f28954-da50-47e9-877b-5dbf659a9bdf label: N/A
    uuid: 0891cfcc-727f-4a2f-91ed-3f6dd2f191c1
  ID-2: /boot/efi raw-size: 512.7 MiB size: 511.7 MiB (99.80%)
    used: 16.4 MiB (3.2%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
    label: NO_LABEL uuid: E892-6523
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A
    uuid: 868F-7F51
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 134.53 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 509 MiB fs: ntfs label: N/A
    uuid: EEB8768BB8765257
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-7:3 info: Acer Integrated Camera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:212b
    class-ID: 0e02
  Device-2: 3-9:4 info: Shenzhen Goodix FingerPrint Device
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 27c6:55a4 class-ID: ef00
  Device-3: 3-10:5 info: Intel AX201 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0026 class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Message: No sensor data found. Is lm-sensors configured?
  Processes: 267 Uptime: 33m wakeups: 2863 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: pacman: 1299 lib: 333 flatpak: 0 Shell: Zsh v: 5.9
  running-in: xfce4-terminal inxi: 3.3.19

Xrandr side of things:

xrandr --listmonitors
Monitors: 1
 0: +*eDP-1 1920/309x1080/173+0+0  eDP-1

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x46 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 4 associated providers: 0 name:modesetting

And I can clearly see that HDMI port is detected, but no connection present for some reason, even tho connector is physically IN and monitor works:

│   ├───Connector 0
│   │   ├───Object ID: 308
│   │   ├───Type: eDP
│   │   ├───Status: connected
│   │   ├───Physical size: 310x170 mm
│   │   ├───Subpixel: unknown
│   │   ├───Encoders: {0}
│   │   ├───Modes
│   │   │   └───1920x1080@60.01 preferred driver nhsync nvsync 
│   │   └───Properties
│   │       ├───"EDID" (immutable): blob = 349
│   │       ├───"DPMS": enum {On, Standby, Suspend, Off} = On
│   │       ├───"link-status": enum {Good, Bad} = Good
│   │       ├───"non-desktop" (immutable): range [0, 1] = 0
│   │       ├───"TILE" (immutable): blob = 0
│   │       ├───"CRTC_ID" (atomic): object CRTC = 98
│   │       ├───"panel orientation" (immutable): enum {Normal, Upside Down, Left Side Up, Right Side Up} = Normal
│   │       ├───"Broadcast RGB": enum {Automatic, Full, Limited 16:235} = Automatic
│   │       ├───"max bpc": range [6, 12] = 12
│   │       ├───"Colorspace": enum {Default, RGB_Wide_Gamut_Fixed_Point, RGB_Wide_Gamut_Floating_Point, opRGB, DCI-P3_RGB_D65, BT2020_RGB, BT601_YCC, BT709_YCC, XVYCC_601, XVYCC_709, SYCC_601, opYCC_601, BT2020_CYCC, BT2020_YCC} = Default
│   │       ├───"HDR_OUTPUT_METADATA": blob = 0
│   │       ├───"scaling mode": enum {Full, Center, Full aspect} = Full aspect
│   │       └───"vrr_capable" (immutable): range [0, 1] = 0
│   ├───Connector 1
│   │   ├───Object ID: 317
│   │   ├───Type: HDMI-A
│   │   ├───Status: disconnected
│   │   ├───Encoders: {1}
│   │   └───Properties
│   │       ├───"EDID" (immutable): blob = 0
│   │       ├───"DPMS": enum {On, Standby, Suspend, Off} = Off
│   │       ├───"link-status": enum {Good, Bad} = Good
│   │       ├───"non-desktop" (immutable): range [0, 1] = 0
│   │       ├───"TILE" (immutable): blob = 0
│   │       ├───"CRTC_ID" (atomic): object CRTC = 0
│   │       ├───"audio": enum {force-dvi, off, auto, on} = auto
│   │       ├───"Broadcast RGB": enum {Automatic, Full, Limited 16:235} = Automatic
│   │       ├───"aspect ratio": enum {Automatic, 4:3, 16:9} = Automatic
│   │       ├───"Colorspace": enum {Default, SMPTE_170M_YCC, BT709_YCC, XVYCC_601, XVYCC_709, SYCC_601, opYCC_601, opRGB, BT2020_CYCC, BT2020_RGB, BT2020_YCC, DCI-P3_RGB_D65, DCI-P3_RGB_Theater} = Default
│   │       ├───"content type": enum {No Data, Graphics, Photo, Cinema, Game} = No Data
│   │       ├───"HDR_OUTPUT_METADATA": blob = 0
│   │       ├───"max bpc": range [8, 12] = 12
│   │       ├───"Content Protection": enum {Undesired, Desired, Enabled} = Undesired
│   │       └───"HDCP Content Type": enum {HDCP Type0, HDCP Type1} = HDCP Type0

Also if I try to connect this very monitor through usb-c hub HDMI, it works, but with low resolution. It looks like some sort of fallback VGA driver stuff to me. I think it might be related to above-mentioned issue.

I’ve already tried a bunch of things, like downgrading all of the mesa/intel drivers (at the time of this report everyting is reverted to the latest versions via pacman -Syyu), kernel update (5.15 → 5.19) and i915 enable_guc=3 parameter, no luck so far.

Help is highly appreciated, thank you!

output from:
mhwd -l && mhwd -li
find /etc/X11/ -name "*.conf"
journalctl -b0 -p3 --no-pager

mhwd -l && mhwd -li
> 0000:2b:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:00:02.0 (0300:8086:9a49) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
find /etc/X11/ -name "*.conf"
Հլս 08 18:24:22 ilia-20vd gdm-password][27266]: gkr-pam: unable to locate daemon control file
Հլս 08 18:24:32 ilia-20vd gdm-launch-environment][26604]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Հլս 08 18:39:57 ilia-20vd kernel: usb 3-2: device not accepting address 61, error -71
Հլս 08 18:40:24 ilia-20vd kernel: usb 3-2: device not accepting address 87, error -71
Հլս 08 18:40:46 ilia-20vd kernel: usb 3-2: device not accepting address 109, error -71
Հլս 08 18:40:55 ilia-20vd kernel: usb 3-2: device not accepting address 117, error -71
Հլս 08 18:41:11 ilia-20vd kernel: usb 3-2: device not accepting address 11, error -71
Հլս 08 18:41:28 ilia-20vd kernel: usb 3-2: device not accepting address 28, error -71
Հլս 08 18:41:44 ilia-20vd kernel: usb 3-2: device not accepting address 42, error -71
Հլս 08 18:42:17 ilia-20vd kernel: usb 3-2: device not accepting address 70, error -71
Հլս 08 18:42:47 ilia-20vd kernel: hub 3-2:1.0: hub_ext_port_status failed (err = -71)
Հլս 08 18:42:55 ilia-20vd kernel: usb 3-2: device descriptor read/all, error -71
Հլս 08 19:09:50 ilia-20vd gdm-wayland-session[27271]: GLib: Source ID 2 was not found when attempting to remove it
Հլս 08 19:09:51 ilia-20vd gnome-session-binary[40069]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Հլս 08 19:09:51 ilia-20vd gnome-session-binary[40069]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Հլս 08 19:09:57 ilia-20vd gdm-password][40318]: gkr-pam: unable to locate daemon control file
Հլս 08 19:09:59 ilia-20vd light-locker[40493]: Environment variable XDG_SESSION_PATH not set. Is LightDM running?
Հլս 08 19:09:59 ilia-20vd systemd-coredump[40593]: [🡕] Process 40493 (light-locker) of user 1000 dumped core.
                                                      Module linux-vdso.so.1 with build-id 1d0e05c7e0de6881e8f40505976b6772f10a9926
                                                      Module libgvfscommon.so with build-id 2cfa9a05d5e376857a2dacaf4893238a88eefb9e
                                                      Module libgvfsdbus.so with build-id f6f918ab413a1eaaa77134863653c4382b7cf8de
                                                      Module libogg.so.0 with build-id ca0cae30a809f10db1f16e54a23b4e5ff7b2c54c
                                                      Module libvorbis.so.0 with build-id f4e086347f6c1a66eb73cfe13974a29bd39aabca
                                                      Module libltdl.so.7 with build-id c4ee3f1ba09fe34163d71ff336756fbecb6f409f
                                                      Module libtdb.so.1 with build-id f2bdb5ac97b6addf2026d93b08c8d15defcd9bb8
                                                      Module libvorbisfile.so.3 with build-id 45d2551167a616d448beb033ba49394831992887
                                                      Module libcanberra.so.0 with build-id 8ddef69c9b84a86062c88a59510639cd908fc6d3
                                                      Module libcanberra-gtk3.so.0 with build-id 2e99c78f79bea4bc67ccd9a9f8fed562f89599ee
                                                      Module libcanberra-gtk-module.so with build-id cc626937222c6ce3f7bb45dbe6e862d0b1efba01
                                                      Module libxkbfile.so.1 with build-id dc74ddc73cb1178f037cdc608f7029a0bc9f69a1
                                                      Module libxklavier.so.16 with build-id cefd678b3d270e389f50a9686ad2db83a8c67494
                                                      Module libgnomekbd.so.8 with build-id 7a75c84337b94141ae6bdf56da86a5a6f72343bf
                                                      Module libgnomekbdui.so.8 with build-id eeb3039b3aa71b38849fb1b3d2e97acb9edab6d4
                                                      Module libxapp.so.1 with build-id 0f5a97cb5baa8ec01af98a40edb3716169927b47
                                                      Module libxapp-gtk3-module.so with build-id dfba3d9cb7e74f66c8a5b8c6f386e2fcf4976381
                                                      Module libdconfsettings.so with build-id 7a4ba7af122c4d11168004a9ea6def330f02089f
                                                      Module libgthread-2.0.so.0 with build-id 3dbf95dc98433e23246eab49e4fe6ceb72a54698
                                                      Module libxfconf-0.so.3 with build-id 05a5980d778faaf25bba2d27249e359b41a796eb
                                                      Module libxfconfgsettingsbackend.so with build-id 8ce01e731b1120543da65b897c044ac6073f4b2b
                                                      Module libbrotlicommon.so.1 with build-id acfd597a977c8087bb6184383daae2e828a9ce42
                                                      Module libstdc++.so.6 with build-id b3eaebcb5369487562e52dd8d016c9cd77f80c54
                                                      Module libicudata.so.71 with build-id 4fef196388e678deb881978139e125e20ee2d94d
                                                      Module libgpg-error.so.0 with build-id 4738b8a9478177c202cccd64e0eb65d3dea2bfae
                                                      Module libblkid.so.1 with build-id 140694a62d8d4d07c6c320a501f948dd1b389d73
                                                      Module libbrotlidec.so.1 with build-id 66c54e9301f7e102ecc1d88547e5f0e8a056fe22
                                                      Module libbz2.so.1.0 with build-id 919597c477c9b2cb9cdbb7745ed6494ac0e6da60
                                                      Module libdatrie.so.1 with build-id 6fe3b6ece2c8e7d11869fa051375128d8f808f58
                                                      Module libxml2.so.2 with build-id 8cdf00fa954d9a27f2f184c4d354cb14677446ac
                                                      Module libjson-glib-1.0.so.0 with build-id 58decebd2c409d59b07f926ae4c513281918bc4d
                                                      Module libsqlite3.so.0 with build-id 143cb4bde0356249e42c865273631c175d738ba1
                                                      Module libicui18n.so.71 with build-id 6fd5c97fd2808ee29958bf809656d5885e7e8963
                                                      Module libicuuc.so.71 with build-id 633fdc0c5385d916571f6140e7a978ad0630ef55
                                                      Module libstemmer.so.0 with build-id 013b48e71279a5ec55e3021fc0bd8fb10a08bae5
                                                      Module libatspi.so.0 with build-id 87bca381f073faea3b0ffd1ab06f5f8f204e24cf
                                                      Module libtiff.so.5 with build-id 31895d2bd133f34f0cdc2d4ac855ed838ec927b6
                                                      Module libjpeg.so.8 with build-id 8e6d3f3e8f438912b561c43b6e7f66e6e5e097d0
                                                      Module libexpat.so.1 with build-id 113bb5a3e9ad856801bfcfc029102c9bdc13d67e
                                                      Module libgraphite2.so.3 with build-id ce58945ebb55b86d3a4e717b6eae29efc4720d8e
                                                      Module libXdmcp.so.6 with build-id d864159ab0008415667db8d5f251696d75c90df2
                                                      Module libXau.so.6 with build-id 60db1eac70f819bea9d4c366603c1583067510b4
                                                      Module libpthread.so.0 with build-id 95ae4f30a6f12ccbff645d30f8e1a3ee23ec7d36
                                                      Module ld-linux-x86-64.so.2 with build-id 0effd0e43efa4468d3c31871c93af0b7f3005673
                                                      Module libgcc_s.so.1 with build-id 0e3de903950e35ae59a5de8c00b1817a4a71ca01
                                                      Module liblz4.so.1 with build-id e63600ab23b2f6997f42fac2fa56e1f02ce159a1
                                                      Module libzstd.so.1 with build-id ab54c2881f53ab314e134f3e08c76d504376dd5d
                                                      Module liblzma.so.5 with build-id 28b40c7af8098a66af6ee093b6986b91cad7694d
                                                      Module libgcrypt.so.20 with build-id 8bf3cb884124273640de797a3e77d86c98434ea4
                                                      Module libcap.so.2 with build-id 21b00ab76bb16fde56fd741f07233c78069f0579
                                                      Module libmount.so.1 with build-id 4436aeea0cd8c01b5a77969e0531184f8b3513ce
                                                      Module libpixman-1.so.0 with build-id d2170a3ac106c2a68597bf7910ab04b1cdd69c14
                                                      Module libxcb-shm.so.0 with build-id 828fec4d856e2710e732ea8d92c3f250c807b1c2
                                                      Module libxcb-render.so.0 with build-id b1ca498d665807ab0ccdafbe8070853efd058173
                                                      Module libXrender.so.1 with build-id 42e386d2acf3cde61081959d9671ca74acfb3edc
                                                      Module libfreetype.so.6 with build-id f89dd5502e75aca28fb5c3ccd0dbd26fe822bfef
                                                      Module libpng16.so.16 with build-id 2dc0bce07f199bf983c07a05fb95a6f4af83a9b3
                                                      Module libz.so.1 with build-id fefe3219a96d682ec98fcfb78866b8594298b5a2
                                                      Module libthai.so.0 with build-id a7ac5010b4275c49308021200d23690533952702
                                                      Module libXinerama.so.1 with build-id 8198240259261b612189e89c9fcfc902b025b382
                                                      Module libXrandr.so.2 with build-id 154e55f082ee9e685d0794c98c5b76ffe9c8868e
                                                      Module libXcomposite.so.1 with build-id 13228d108b290268d88510db494daefd5521cda0
                                                      Module libXdamage.so.1 with build-id a99dbe3fc2b01da9fbdd90d5ad00621f9022379f
                                                      Module libXcursor.so.1 with build-id f0525ae3715ac95f96a8cdb44795b03f831334b0
                                                      Module libwayland-egl.so.1 with build-id ac45e227422559ff92c4d04851fffb8452874713
                                                      Module libwayland-cursor.so.0 with build-id 647d92328111682fb15bff1c20a4c9368414857c
                                                      Module libwayland-client.so.0 with build-id 95e7368b400dd57e3db2a5c385de71c7dca08879
                                                      Module libxkbcommon.so.0 with build-id 6cf66eead3fcc20fe5df10162bfbcdcdc8b2a183
                                                      Module libXfixes.so.3 with build-id 0a05c7e8714522bfbdd7c0027c3e2a94965664b0
                                                      Module libtracker-sparql-3.0.so.0 with build-id cf34149783308bf03d370cd6a9839cf85c35dae6
                                                      Module libcloudproviders.so.0 with build-id ed1d9c9e60be4e858ad148484767249be1edf95f
                                                      Module libatk-bridge-2.0.so.0 with build-id 1161ebbcc5aa791075dfa026671875e5417287bd
                                                      Module libXi.so.6 with build-id 16603be937a02a7e61b0b0395d064be7efd86f49
                                                      Module libm.so.6 with build-id 1b7296ef9fd806e47060788389293c824b09ad72
                                                      Module libepoxy.so.0 with build-id edc178a150c4255d124e1e1ecbdbecebd1a388cd
                                                      Module libatk-1.0.so.0 with build-id c2de8b4fcbd9681cef225fe3956a9608a2a664bb
                                                      Module libgdk_pixbuf-2.0.so.0 with build-id 5b8422ab971b1a8a8e1c43b88738d4ee217f609e
                                                      Module libcairo-gobject.so.2 with build-id 9927090dddfb180365695a8f37d1cac89463f109
                                                      Module libfribidi.so.0 with build-id fe9f35ac2a0074108c8306c517793f7279bd9b37
                                                      Module libfontconfig.so.1 with build-id 36be6951b8c1e42a7dd05684a37400fc8ef9147c
                                                      Module libpangoft2-1.0.so.0 with build-id c2c09f789578900f61b7fca4a4311d8b94d9a750
                                                      Module libharfbuzz.so.0 with build-id 4b8338b259318d7786bb1f4a702954f2e74fb3dd
                                                      Module libgmodule-2.0.so.0 with build-id 3b42a54783f0665e688370b6c57238c05822c50e
                                                      Module libxcb.so.1 with build-id 13d677412a71468381b11092915d231f664d18d3
                                                      Module libpcre.so.1 with build-id 845483dd0acba86de9f0313102bebbaf3ce52767
                                                      Module libffi.so.8 with build-id f0a9586cf0f42d2b9971bd1065ca3a6b19f4a2c2
                                                      Module libc.so.6 with build-id 60df1df31f02a7b23da83e8ef923359885b81492
                                                      Module libsystemd.so.0 with build-id 6430b2bd03335142b596061e30d2508dc604a1b4
                                                      Module libgio-2.0.so.0 with build-id bc795ed533f1b5c20cdc8600cf855216d692087f
                                                      Module libcairo.so.2 with build-id a222d042e56108d2786ece7bf291b56ba2069591
                                                      Module libpango-1.0.so.0 with build-id 7e27c1e46a1d958f6b16e1ba199f8bdb3f100566
                                                      Module libpangocairo-1.0.so.0 with build-id b65f507d9e33adfbd19369acef5e5a0a2422c6d1
                                                      Module libgdk-3.so.0 with build-id 4a9a6d5ddd18f22c56c05773208f8808cefacab6
                                                      Module libgtk-3.so.0 with build-id 48baf44dfd4d51f8c2b81d852eb44de692c16b19
                                                      Module libXss.so.1 with build-id a3b819a932d6eb2b4fbfd0c6bd77242ef14e7366
                                                      Module libXext.so.6 with build-id 17beadf1cb40d41ab36629db3b4eed74110678a7
                                                      Module libX11.so.6 with build-id 310f8f1b8d7457d326407e0eb794353c62769b73
                                                      Module libglib-2.0.so.0 with build-id f1d15261ce1317b9003a1f0957d5a528d063f630
                                                      Module libgobject-2.0.so.0 with build-id a7dfc5c24acdbd0bcc40e3a427f917f679eef0d1
                                                      Module libdbus-1.so.3 with build-id 7f4b16b4b407cbae2d7118d6f99610e29a18a56a
                                                      Module libdbus-glib-1.so.2 with build-id 9b483ffff76251ff057e007a0b960bff84ce34a8
                                                      Module light-locker with build-id c965faf0b9b80fafa2990b2cdf78010738bc40c6
                                                      Stack trace of thread 40493:
                                                      #0  0x00007f90feecf068 g_log_structured_array (libglib-2.0.so.0 + 0x5c068)
                                                      #1  0x00007f90feecf343 g_log_default_handler (libglib-2.0.so.0 + 0x5c343)
                                                      #2  0x00007f90feed0825 g_logv (libglib-2.0.so.0 + 0x5d825)
                                                      #3  0x00007f90feed0ad4 g_log (libglib-2.0.so.0 + 0x5dad4)
                                                      #4  0x000055ae82ddd836 n/a (light-locker + 0xb836)
                                                      #5  0x00007f90fefed0db g_type_create_instance (libgobject-2.0.so.0 + 0x3d0db)
                                                      #6  0x00007f90fefd3b29 n/a (libgobject-2.0.so.0 + 0x23b29)
                                                      #7  0x00007f90fefd4d91 g_object_new_with_properties (libgobject-2.0.so.0 + 0x24d91)
                                                      #8  0x00007f90fefd586a g_object_new (libgobject-2.0.so.0 + 0x2586a)
                                                      #9  0x000055ae82ddf010 n/a (light-locker + 0xd010)
                                                      #10 0x00007f90fefed0db g_type_create_instance (libgobject-2.0.so.0 + 0x3d0db)
                                                      #11 0x00007f90fefd3b29 n/a (libgobject-2.0.so.0 + 0x23b29)
                                                      #12 0x00007f90fefd4d91 g_object_new_with_properties (libgobject-2.0.so.0 + 0x24d91)
                                                      #13 0x00007f90fefd586a g_object_new (libgobject-2.0.so.0 + 0x2586a)
                                                      #14 0x000055ae82dd8372 n/a (light-locker + 0x6372)
                                                      #15 0x00007f90fdc29290 n/a (libc.so.6 + 0x29290)
                                                      #16 0x00007f90fdc2934a __libc_start_main (libc.so.6 + 0x2934a)
                                                      #17 0x000055ae82dd8be5 n/a (light-locker + 0x6be5)
                                                      Stack trace of thread 40504:
                                                      #0  0x00007f90fdd05c3f __poll (libc.so.6 + 0x105c3f)
                                                      #1  0x00007f90fef1df68 n/a (libglib-2.0.so.0 + 0xaaf68)
                                                      #2  0x00007f90feec5392 g_main_context_iteration (libglib-2.0.so.0 + 0x52392)
                                                      #3  0x00007f90feec53e2 n/a (libglib-2.0.so.0 + 0x523e2)
                                                      #4  0x00007f90feef7405 n/a (libglib-2.0.so.0 + 0x84405)
                                                      #5  0x00007f90fdc8c54d n/a (libc.so.6 + 0x8c54d)
                                                      #6  0x00007f90fdd11874 __clone (libc.so.6 + 0x111874)
                                                      Stack trace of thread 40517:
                                                      #0  0x00007f90fdd05c3f __poll (libc.so.6 + 0x105c3f)
                                                      #1  0x00007f90fef1df68 n/a (libglib-2.0.so.0 + 0xaaf68)
                                                      #2  0x00007f90feec71cf g_main_loop_run (libglib-2.0.so.0 + 0x541cf)
                                                      #3  0x00007f90fe1b295c n/a (libgio-2.0.so.0 + 0x10895c)
                                                      #4  0x00007f90feef7405 n/a (libglib-2.0.so.0 + 0x84405)
                                                      #5  0x00007f90fdc8c54d n/a (libc.so.6 + 0x8c54d)
                                                      #6  0x00007f90fdd11874 __clone (libc.so.6 + 0x111874)
                                                      Stack trace of thread 40505:
                                                      #0  0x00007f90fdd05c3f __poll (libc.so.6 + 0x105c3f)
                                                      #1  0x00007f90fef1df68 n/a (libglib-2.0.so.0 + 0xaaf68)
                                                      #2  0x00007f90feec5392 g_main_context_iteration (libglib-2.0.so.0 + 0x52392)
                                                      #3  0x00007f90fa9f6ebe n/a (libdconfsettings.so + 0x5ebe)
                                                      #4  0x00007f90feef7405 n/a (libglib-2.0.so.0 + 0x84405)
                                                      #5  0x00007f90fdc8c54d n/a (libc.so.6 + 0x8c54d)
                                                      #6  0x00007f90fdd11874 __clone (libc.so.6 + 0x111874)
                                                      ELF object binary architecture: AMD x86-64
Հլս 08 19:10:08 ilia-20vd gnome-session-binary[40069]: GLib-CRITICAL: g_hash_table_foreach_remove_or_steal: assertion 'version == hash_table->version' failed
Հլս 08 19:10:08 ilia-20vd gdm-launch-environment][40049]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

I’m pretty sure that usb errors are related to usb-c hub

i had a similar problem with a broken hdmi-cable. there was no visual failure but the cable didn’t work properly. changing the cable is a possible fix. also check the settings of the screen-setup of the monitor itself.

I’ve also forgot to mention, I normally run sway, not Xfce, but for debugging purposes I’ve tried using some other WM. Above mentioned issue persist in sway, and all the symptoms are exactly the same.

I’m gonna try that a bit later, don’t have spare cable on hand

everything looks ok, except the dumped core… and did it work in live usb, or at any other time?
also ollis suggestion regarding the cable is good

It worked couple of days ago, and it suddenly stopped. I’ve suspected update at first, but now think it might be faulty cable, need to try out new one

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.