External monitor not detected after installation - does work on live CD

Hello, i’ve decided to try Manjaro and the live CD was a beautiful experience.
I’m using a laptop (Dell inspiron with an nvidia g.card).
while using the Live CD version (boot using thumb drive), my external display was functioning well.
It seems that manjaro installed with nvidia drivers which detect the discrete graphics card, but not the display (which is connected using HDMI).

I’ve tried installing optimus-manager, which didn’t change much.
xrandr only lists one display - the integrated laptop one.

Thank you in advance.

please post the output of

inxi -v8zy
  Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=e143a976-64c2-45df-9b09-6dd59036365c rw quiet splash
    resume=UUID=ca41b1b6-f615-4023-8c90-3ccd212b9c10 udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 065C71 v: A00 serial: <superuser required> part-nu: 0798
    uuid: <superuser required> UEFI: Dell v: 1.15.0 date: 08/30/2021
  ID-1: BAT0 charge: 54.1 Wh (100.0%) condition: 54.1/74.0 Wh (73.1%)
    volts: 12.9 min: 11.1 model: Samsung SDI DELL 0GFJ6F4 type: Li-ion
    serial: <filter> status: full
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  System RAM: total: 16 GiB available: 15.49 GiB used: 3.22 GiB (20.8%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 32 GiB slots: 2 modules: 1 EC: None
    max-module-size: 16 GiB note: est.
  Device-1: DIMM A type: DDR4 detail: synchronous size: 16 GiB
    speed: 2400 MT/s volts: note: check curr: 1 min: 1 max: 1 width (bits):
    data: 64 total: 64 manufacturer: Kingston part-no: K821PJ-MIB
    serial: <filter>
  Device-2: ChannelB-DIMM0 type: no module installed
PCI Slots:
  Permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 800/3800 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 44817
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep
    smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1 bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell
    driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1c8c
    class-ID: 0300
  Device-3: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-12:5
    chip-ID: 1bcf:28c1 class-ID: 0e02
  Display: wayland server: X.org v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting dri: iris
    gpu: i915,nvidia display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 2 drv: swrast surfaceless:
    drv: nvidia wayland: drv: iris x11: drv: iris inactive: gbm
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 630 (KBL GT2)
    device-ID: 8086:591b memory: 15.13 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.276 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1050 Ti driver: nvidia v: 550.54.14 device-ID: 10de:1c8c
    surfaces: xcb,xlib,wayland
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  API: ALSA v: k6.6.19-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Dell RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:3165 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Info: services: NetworkManager,wpa_supplicant
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:4 chip-ID: 8087:0a2a
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 1.03 TiB used: 10.67 GiB (1.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: THNSNK128GVN8 M.2 2280
    128GB size: 119.24 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 4101 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10JPVX-75JC3T0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A03 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 101.91 GiB size: 99.75 GiB (97.88%) used: 10.67 GiB (10.7%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: e143a976-64c2-45df-9b09-6dd59036365c
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 0C7D-A3F4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 17.04 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: ca41b1b6-f615-4023-8c90-3ccd212b9c10
  ID-1: /dev/sdb1 maj-min: 8:17 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/sdb2 maj-min: 8:18 size: 489.11 GiB fs: ntfs label: The
    uuid: 34AA40E6AA40A668
  ID-3: /dev/sdb3 maj-min: 8:19 size: 442.38 GiB fs: ext4 label: N/A
    uuid: ffb3b7f2-a75c-40d0-96e8-3e46b1289f83
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-2:2 info: Logitech USB Receiver type: keyboard,mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c53f class-ID: 0300
  Device-2: 1-3:3 info: Kingston HyperX Alloy Origins Core type: keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 500mA chip-ID: 0951:16e6 class-ID: 0300
  Device-3: 1-4:4 info: Intel Bluetooth wireless interface type: bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 power: 100mA chip-ID: 8087:0a2a class-ID: e001
  Device-4: 1-12:5 info: Sunplus Innovation Integrated_Webcam_HD type: video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 1bcf:28c1 class-ID: 0e02
  Hub-2: 2-0:1 info: super-speed hub ports: 8 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 49.0 C pch: 44.5 C mobo: 38.0 C sodimm: SODIMM C
  Fan Speeds (rpm): cpu: 0
  Packages: pm: pacman pkgs: 1138 libs: 329 tools: pamac pm: flatpak pkgs: 0
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https://ask4.mm.fcix.net/manjaro/stable/$repo/$arch
    2: https://mirror.bouwhuis.network/manjaro/stable/$repo/$arch
    3: http://manjaro.grena.ge/stable/$repo/$arch
  CPU top: 5 of 231
  1: cpu: 6.4% command: firefox pid: 1222 mem: 547.7 MiB (3.4%)
  2: cpu: 2.4% command: kwin_wayland pid: 698 mem: 348.7 MiB (2.1%)
  3: cpu: 1.5% command: plasmashell pid: 860 mem: 460.7 MiB (2.9%)
  4: cpu: 1.2% command: firefox pid: 2067 mem: 129.0 MiB (0.8%)
  5: cpu: 1.0% command: firefox pid: 1543 mem: 291.7 MiB (1.8%)
  Memory top: 5 of 231
  1: mem: 547.7 MiB (3.4%) command: firefox pid: 1222 cpu: 6.4%
  2: mem: 460.7 MiB (2.9%) command: plasmashell pid: 860 cpu: 1.5%
  3: mem: 348.7 MiB (2.1%) command: kwin_wayland pid: 698 cpu: 2.4%
  4: mem: 291.7 MiB (1.8%) command: firefox pid: 1543 cpu: 1.0%
  5: mem: 260.3 MiB (1.6%) command: konsole pid: 2207 cpu: 0.8%
  Processes: 231 Power: uptime: 31m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.18 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.33

okay step 1:
post the output of

echo $XDG_SESSION_TYPE && glxinfo | grep server

you’ll see that you’re running wayland what doesn’t charm with nvidia.
reboot and look at the login-screen at the left, bottom corner. there is a menu where to choose between wayland and x11. choose x11, login, repeat the command to make sure you’re on x11.
the other output is the gpu. sgi = intel, nvidia is that what we’ll want. but first things first.
report if you done the first steps.

Everything’s just as you said.
glx vendor is “sgi”.

you’re on x11 now ?

Sometimes I’m prompted to select if I want to display on one screen or the other, it doesn’t matter what I choose though - nothing changes and I’m prompted again a few moments later.

i’ve tried to run:

optimus-manager --switch hybrid

after logging in again, the display freezes on the loading screen.

that’s clear, your type of laptop is hardwired. this means you can use the laptopdisplay on intel or nvidia but the external display need the use of the nvidia card.
next step, install envycontrol to switch the cards

pamac install envycontrol

stop, disable and mask optimus (you can remove it later if everything is fine)

sudo systemctrl stop optimus-manager && sudo systemctrl disable optimus-manager && sudo systemctrl mask optimus-manager

make sure optimus is disabled

systemctrl status optimus-manager

it must be inactive

use envycontrol to switch to nvidia

sudo envycontrol -s nvidia

reboot, login and check again

echo $XDG_SESSION_TYPE && glxinfo | grep server 

nvidia ? if not, no problem. in this case we’ll edit grub but try this first

1 Like

I hope this thread helps more people.
For future reference:
After inputting:
sudo systemctrl stop optimus-manager && sudo systemctrl disable optimus-manager && sudo systemctrl mask optimus-manager
i had to correct “systemctrl” to systemctl.
Also, for some reason optimus-manager simply doesn’t exist (Command not found).

Regardless, the external monitor works well and becomes the primary display once i close the laptop’s lid.

Much appreciated Olli!

1 Like

that’s why i thought it’s installed.

a little bit late and a little bit tired, sorry for the typo-mismatch.

It was, i have no clue how it disappeared - I did not remove it and was using it moments before you’ve solved the problem.

Cheers for the effort - thank you.

check the system-settings → display
you can configure it from there

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.