External monitor drops refresh rate to 1 FPS when scaled 2x2 with xrandr


I am using KDE Manjaro and I have been having an issue with scaling my external monitor for past 1 year.

I have a 4K laptop Dell XPS and I am using an 1080p external monitor. As you’d suspect I have to scale my external monitor to my laptop and it does work, but the background is displayed only a quarter of the screen. However, the real problem is that the refresh rate drops to 1 FPS (unusable) in the black region.

xrandr --output HDMI-1 --auto --scale 2x2

Gnome had the same behaviour 1.5 years when I first used Manjaro, but it seems they got this figured out after all.
I found other posts on different forums about the same issue, but no follow up on solving it:

Running glxgears both on Mesa(Intel) or Nvidia shows the refresh rate problem I mentioned. The 60ish FPS is for my 4K laptop screen and windows that are at least partially outside of the black region, whereas the 1 FPS is for windows totally in the black region. The two figures below depict this scenario.

--- ~ » glxgears                                                              130 ↵
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
420 frames in 5.0 seconds = 83.939 FPS
301 frames in 5.0 seconds = 60.078 FPS
301 frames in 5.0 seconds = 60.181 FPS
298 frames in 5.0 seconds = 59.595 FPS
115 frames in 6.0 seconds = 19.178 FPS
5 frames in 5.0 seconds =  1.000 FPS
6 frames in 6.0 seconds =  1.000 FPS

--- ~ » inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/Manjaro/vmlinuz-5.9-x86_64 
  root=UUID=22d1971a-92c2-4ce0-aa98-314d959f53cd rw rootflags=subvol=@ quiet 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: XPS 15 9550 v: N/A serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0N7TVV v: A01 serial: <filter> UEFI: Dell v: 1.13.1 
  date: 12/12/2019 
  ID-1: BAT0 charge: 13.1 Wh condition: 13.1/84.0 Wh (16%) volts: 12.4/11.4 
  model: LGC-LGC3.67 DELL T453X type: Li-ion serial: <filter> status: Full 
  Device-1: hid-78:05:19:10:01:55-battery model: Bluetooth 3.0 Keyboard 
  serial: N/A charge: N/A status: Discharging 
  RAM: total: 15.45 GiB used: 3.65 GiB (23.6%) 
  RAM Report: missing: Required program dmidecode not available 
  Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: E2 
  L2 cache: 6144 KiB bogomips: 41621 
  Speed: 900 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 900 5: 900 6: 900 7: 900 8: 900 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: Intel HD Graphics 530 vendor: Dell XPS 15 9550 driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
  Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Dell XPS 15 9550 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:139b 
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-12:6 chip ID: 0c45:6713 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 7680x2160 s-dpi: 193 s-size: 1013x285mm (39.9x11.2") 
  s-diag: 1052mm (41.4") 
  Monitor-1: eDP-1 res: 3840x2160 hz: 60 dpi: 282 size: 346x194mm (13.6x7.6") 
  diag: 397mm (15.6") 
  Monitor-2: HDMI-1 res: 3840x2160 hz: 60 dpi: 184 
  size: 531x299mm (20.9x11.8") diag: 609mm (24") 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Dell XPS 15 9550 driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  chip ID: 8086:a170 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel modules: wl 
  port: e000 bus ID: 02:00.0 chip ID: 8086:24f3 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 983.05 GiB used: 145.36 GiB (14.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Sabrent model: N/A size: 953.87 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: RKT303.3 scheme: GPT 
  ID-2: /dev/sda type: USB vendor: SanDisk model: Cruzer Switch 
  size: 29.18 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 633.87 GiB size: 633.87 GiB (100.00%) 
  used: 145.18 GiB (22.9%) fs: btrfs dev: /dev/nvme0n1p6 label: N/A 
  uuid: 22d1971a-92c2-4ce0-aa98-314d959f53cd 
  ID-2: /efi raw size: 600.0 MiB size: 598.8 MiB (99.80%) 
  used: 184.4 MiB (30.8%) fs: vfat dev: /dev/nvme0n1p1 label: N/A 
  uuid: E872-4047 
  ID-3: /home raw size: 633.87 GiB size: 633.87 GiB (100.00%) 
  used: 145.18 GiB (22.9%) fs: btrfs dev: /dev/nvme0n1p6 label: N/A 
  uuid: 22d1971a-92c2-4ce0-aa98-314d959f53cd 
  ID-4: /run/timeshift/backup raw size: 633.87 GiB size: 633.87 GiB (100.00%) 
  used: 145.18 GiB (22.9%) fs: btrfs dev: /dev/nvme0n1p6 label: N/A 
  uuid: 22d1971a-92c2-4ce0-aa98-314d959f53cd 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 20.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p5 label: N/A uuid: 4dd57c94-0b7a-402b-b212-f883f2857370 
  ID-1: /dev/nvme0n1p2 size: 16.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-2: /dev/nvme0n1p3 size: 298.91 GiB fs: ntfs label: N/A 
  uuid: 38F8D890F8D84DAE 
  ID-3: /dev/nvme0n1p4 size: 498.0 MiB fs: ntfs label: N/A 
  uuid: 7E2A58D32A588A53 
  ID-4: /dev/sda1 size: 29.18 GiB fs: vfat label: MULTIBOOT uuid: 09E9-2F3D 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 1-1:2 info: Dell Universal Bluetooth Receiver 
  type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s chip ID: 413c:301b 
  Device-2: 1-2:3 info: SanDisk Cruzer Switch type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s 
  chip ID: 0781:5572 serial: <filter> 
  Device-3: 1-4:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0a2b 
  Device-4: 1-9:5 info: Elan Micro Touchscreen type: HID 
  driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 04f3:21d4 
  Device-5: 1-12:6 info: Microdia Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0c45:6713 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 62.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2509 fan-2: 2517 
  Processes: 310 Uptime: 1h 52m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: 1217 pacman: 1206 lib: 378 flatpak: 11 Shell: Zsh v: 5.8 
  running in: konsole inxi: 3.1.08

Has anyone met this issue before? I would be very grateful if anyone has advices that can help me solve this.

It really disturbs my workflow because I cannot do any sort of tiling.

You could use 1920x1080 on the 4k. :slight_smile:

I have a desktop, but I used to have a quarter screen like that when I logged in (never tested fps), these are the commands I used, not sure if the differences will make a difference (probably not unless it’s position/resolution related).

xrandr --output HDMI-2 --pos 0x0 --mode 1920x1080 --scale 2x2 
xrandr --output HDMI-0 --mode 3840x2160 --pos 3840x0

I currently have both set to 1080, as there were some minor annoyances with scaling the fb. The one that bothered me was that windows would only show on the 1080’s panel if they were in the top left corner of the screen, that got in the way of my workflow.

You should probably post the output of xrandr and any xorg config you have.

I have tried your xrandr commands, but they lead me to the same result.

Previously, I have used 1080p on my 4K to go around this issue, but I would prefer to keep it at 4K.
While many would argue that there isn’t much difference between 4K and 1080p, it is in fact noticeable, especially when reading.

--- ~ » xrandr
Screen 0: minimum 320 x 200, current 7680 x 2160, maximum 16384 x 16384
eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 346mm x 194mm
   3840x2160     60.00*+  59.98    59.97  
   3200x1800     59.96    59.94  
   2880x1620     59.96    59.97  
   2560x1600     59.99    59.97  
   2560x1440     59.99    59.99    59.96    59.95  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   2048x1152     59.99    59.98    59.90    59.91  
   1920x1200     59.88    59.95  
   1920x1080     60.01    59.97    59.96    59.93  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 3840x2160+3840+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

My Xorg is generated by optimus-manager, but I had the same issue even without it.

Section "ServerLayout"
        Identifier "layout"
        Screen 0 "intel"
        Inactive "nvidia"
        Option "AllowNVIDIAGPUScreens"

Section "Device"
        Identifier "intel"
        Driver "modesetting"
        BusID "PCI:0:2:0"
        Option "DRI" "3"

Section "Screen"
        Identifier "intel"
        Device "intel"

Section "Device"
        Identifier "nvidia"
        Driver "nvidia"
        BusID "PCI:1:0:0"
        Option "Coolbits" "28"

Section "Screen"
        Identifier "nvidia"
        Device "nvidia"

Didn’t think they would, but ya never know. Sorry I don’t have any experience with hybrid graphics, so probably not gonna be much help.

Completely agree with you, although the fonts on my 1080 can look pretty bad when scaled, at least next to the 4k. I forget I’ve got AMD now, might be better (or worse), probably won’t help with windows appearing on the wrong panel though. :frowning:

Good luck, I hope you find a solution soon. :slight_smile:

1 Like