External Keyboard Backlight Not Working

Hi,

I’m using Manjaro Gnome Edition and laptop is lenovo thinkbook 14ML 1st Generation.

Issue Name

: "External Keyboard Backlight is not working

Keyboard Brand: China Lokai with RGM backlight

This is the output with lsusb

Bus 001 Device 007: ID 1a2c:2124 China Resource Semico Co., Ltd Keyboard

(I’ve tried)

  1. xset led on - not working and do not give any output

  2. This article of Backlight Working by WhizSid

I apprecaite your time and support for this.

I use a keyboard with backlight which is controlled by using special hotkey key combinations.

There is a key to switch on and off backlight but it is not working in linux. However, keyboard backlight turning on at booting only and switching off when a login screen appears. I tried google a way to solve this issue and unfortunately, there is no proper solution for this.

Thanks for your time :slight_smile:

That seems to indicate you need a software to do it - a software which is not an ordinary part of the kernel.

When you run lsusb you will get an id of the keyboard.

xxxx:yyyy

Then search the internet for keyboard backlight vid xxxx pid yyyy

1 Like

Thanks. I’d tried this method but there is no specific drivers or software available for the keyboard.
:slight_smile:

No I imagine there wouldn’t be unless it’s a programmable keyboard. Unfortunately you still haven’t told us what keyboard it is, so we can only imagine. We know the brand but not the model.

As you and @linux-aarhus said, there’s a key for it. The key will be dealt with in the firmware, since the firmware both detects the key being pressed and turns off the backlight.

I think either it needs another key in combination, it’s broken or perhaps something on the pc is sending something to the keyboard to keep the LEDs off. I don’t think the latter is likely but :man_shrugging:.

Is it a new keyboard?
Has the backlight key ever worked?
Does it work in another OS/distro/live USB?
Does it work before the login screen?
Do you have an Fn key? If so try using it with your backlight key.
Check your settings for something to do with the keyboard backlight.

Mine also has Fn + PgUp and Fn + PgDn to increase and decrease the brightness, they turn the LEDs on/off (but they only work if the colour scheme isn’t set to off). You could try those.