External hard drive: Could not mount this device

I have an external HDD that up until a couple days ago auto-mounted just fine, and that I could mount and unmount through “Disks and Devices” in the task manager.
Now when I boot, it says “Could not mount this device.”
If I try clicking “Mount” or “Mount and Open” it says “Accessing” for a moment, and then goes back to listing the unmounted drive (without an error message).

I CAN mount the drive with the mount command… and unmount it through the GUI, but I’d like to get this feature working again and I don’t know where to start.
My other external drive (same physical cables and ports) behaves normally.
The drive is healthy and behaves normally in Windows.

KDE Plasma: 5.27.8
Kernel: 6.1.55-1-MANJARO (64-bit)

sudo pacman -Syu ntfs-3g
echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf

… and reboot. Cheers.


Let me guess, its file system is NTFS? If so, make sure ntfs-3g is installed and enter in konsole:

echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf
sudo mkinitcpio -P
sudo update-grub

and reboot afterwards.


This worked - thank you.
Any idea why it broke in the first place?

A new module ntfs3 has been introduced with kernels > 5.15 … in the past the functionality was provided with an additional package - ntfs-3g.
Its not exactly rare for people to report problems with the newer module and/or still prefer ntfs-3g.
The commands above ensure you have the package installed and blacklists the new ntfs3 module.

1 Like

The explanation above is accurate.

The commands I gave, in order, did this:

  1. Installed ntfs-3g (or reinstalled, if it was already installed)
  2. Blacklisted the ntfs3 (in-kernel driver) for NTFS

Note that Wollie also gave the same response, but with two additional commands that might have helped rejuvenate the boot files, if needed. They were not needed in this instance (but could have been).


Many thanks for the explanation and the help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.