External DVD Drive Only Mounts Some DVDs

My external drive will mount some DVDs and not others. I tried with Windows 10, and it was able to read all the DVDs with the same drive. I also tried using Ubuntu 18 and Ubuntu 20, but encountered the same problem as Manjaro.

With my Manjaro install, I’ve tried 5.4 and 5.7 kernels. For DVDs that don’t mount, i don’t see the DVD in file manager and VLC outputs:

Your input can't be opened:
VLC is unable to open the MRL 'dvd:///dev/sr0'. Check the log for details.

Info on my drive:

$ inxi -dxx
Drives:
  Local Storage: total: 953.87 GiB used: 9.35 GiB (1.0%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW1T0HMLH-000L7 
  size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial:  
  Optical-1: /dev/sr0 vendor: ASUS model: BW-16D1HT rev: 3.10 dev-links: N/A 
  Features: speed: 47 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 

Thanks for any insight or suggestions!

Welcome at the forum, @as3adtintin,

This looks to be a matter of different drivers between Windoze and Linux. Windoze is often much better supported by the manufacturer if the devices are still new. You could try kernel 5.8 as well.

Can you characterize the specific difference between the DVD’s working and not working?

It could be between different DVD formats or it could be VLC. Try installing SM Player and mplayer. They may be able to read it. VLC seems to be getting more outdated and clumsy despite all the “industry standard” type recommendations.

Thanks, @Wollie and @wordler for the suggestions!

I haven’t found a pattern between DVDs working and not working. For instance, right now I have a professionally (not pirated) made tv series with five discs. Four of the discs work with Manjaro, but one of them won’t mount. That one that won’t mount will mount in Windows. I also installed 5.8, but no luck there either :confused:

I tried using MPlayer, but it says Mplayer/mpv has finished unexpectedly. Error code: 2. I don’t think a different player would work if the disc isn’t mounting at all (but I pretty new to this stuff so…).

If it helps, after I have trouble mounting a DVD, if I try to shut the computer down, the shut down hangs until I unplug the external drive. When I unplug the external drive it shows the following briefly before shutting down:

Waiting for process: systemd-udevd, dd, eject systemd-udevd, blkid, (sd-sync), (sd-sync)
blk_update_request: I/O error, dev sr0, sector 2038 op 0x0:(READ) flags 0x0 phys_seg 2 prio class @ 
Buffer I/O error on dev sr0, logical block 512, async page read
... and more of similar blk_update_request errors and buffer i/o errors

Look like a read error. Checking the dvd, if there are errors might be good idea.

dvdisaster is good tool for this:

pamac build dvdisaster
1 Like