External drives are on root permissions

Hello there,

Suddenly, I don’t have permissions to edit anything in my eternal drives that I mounted before and added them to fstab file.
I tried this option

sudo chown $USER:$USER /mnt/drive_name

But nothing happened. Still, the 2 drives are set to root permissions.

This is my device info https://i.imgur.com/2OgzCbG.png.

Thanks in advaance.

of course not
The destination is missing - the command is incomplete.
To what device/to what directory on it did you want this chown to refer to?
You didn’t say - you didn’t specify it in that command.

This is almost useless info
it’s only telling about the OS version and the processor in your machine - not about drives or filesystems on them …
inxi -Fazy (for example)
would be more helpful

… the /etc/fstab entry that you have as well

NTFS filesystem?
ext4 filesystem?

If it worked before, but not anymore, the file system might contain errors and it needs to be checked and repaired
before it will again be working as before.

I am sorry, I didn’t mention that, but I did write the destination like this sudo chown $USER:$USER /mnt/Data. That’s exactly what I wrote. The external hard drive is called Data.

The drives are both NTFS and working very fine till today.
Yes, it was working perfectly, how can I check those errors.

Also, which info do you want to know from inxi -Fazy.

I read them, but can’t find a solution for my issue.

Please post the output of… :arrow_down:

cat /etc/fstab | grep -i ntfs
mount | grep -i ntfs
uname -r
ls -l /mnt

Here it’s

UUID=01D6D6DDA6146800   /mnt/Data       ntfs    defaults        0       0 
UUID=5E7E4E247E4DF575   /mnt/Fun        ntfs    defaults        0       0

Please don’t post images. Copy the terminal input with the mouse, click on the </> button in the toolbar, and paste the copied content in between the two lines of three backticks each.

That said, you are using the deprecated ntfs drtiver, which only allows read-only access. Change it to ntfs-3g and remount the filesystems.

for fs in /mntData /mnt/Fun ; do sudo mount -t ntfs-3g -o remount $fs ; done

And by the way… :arrow_down:

This little detail is mentioned in those tutorials.

Sorry for that, I edited it.

So, I change ntfs to ntfs-3g inside fstab and reboot? That’s it?

No need to reboot. You can remount them — see my above post. But yes, you have to edit /etc/fstab.

perhaps - but perhaps the file system needs checking and repairing.
This can only be done reliably under/with Windows.

1 Like

I changed the fstab as you said and entered this above command, but it gives me this:

Remounting is not supported at present. You have to umount volume and then mount it once again.
Remounting is not supported at present. You have to umount volume and then mount it once again.

And still the same problem.

I have dual system. What can I do with Windows?

boot into it, have it check the drives in question
and make sure you really shut Windows down before you attempt to access any drive that was connected to it
from without Windows (from Manjaro …)

cd / && for fs in /mntData /mnt/Fun ; do sudo umount $fs && sudo mount -t ntfs-3g $fs ; done

What @Nachlese means is that you must make sure that Windows Fast Boot or Hybrid Sleep — whatever it’s called — is disabled.

If it’s enabled, then Windows does not properly shut down its filesystems, leaving them in an open state. The Linux kernel then sees those filesystems as damaged and will mount them read-only so as to prevent further filesystem damage.

Unfortunately, same message.

By using chkdsk??

Sorry, I didn’t get this.

Reboot into Windows, run a CHKDSK.EXE on those partitions, disable Fast Boot and/or Hybrid Sleep, shut down Windows, and reboot into Manjaro again.

It gives me that:

umount: /mnt/Data: not mounted.
umount: /mnt/Fun: not mounted.

I’m not a Windows user, but I think that might be correct.

… not just shut it down - it has got a feature that enables faster start up - leaving the file systems
(from the perspective of another OS)
in a “dirty” state.

google how to fully shut down windows …