ExpressVPN daemon doesn't automatically start after boot

I successfully installed ExpressVPN. When I boot, I notice ExpressVPN isn’t starting because my internet connection is blocked. I run:

expressvpn connect

And get:

It seems that the expressvpn daemon is not running. Please run "sudo service expressvpn restart" to start it.

I then run:

sudo service expressvpn restart

And get:

sudo: service: command not found

This fixes it:

systemctl start expressvpn

ExpressVPN then starts working as normal. But I’d like to not have to run this command every time I boot. What can I do?

This is a fresh Manjaro install. ExpressVPN worked fine on a past Manjaro install, though I may have used a different installation method. Also currently works fine on Ubuntu.

1 Like

Because thats incorrect.
Thats an ubuntu alias, not a real command.
It should be:

systemctl start expressvpn

You can tell expressvpn that their client and instructions are faulty if you like :wink:

The same you would with any other service - enable it

systemctl enable expressvpn

(if you use the extra flag --now then it will also ‘start’ it)


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.