[Experiment] Using an Odroid N2 as my desktop

Well, progress has been stagnant for a little while now.

So there’s still no OpenGL acceleration in Plasma, but the rest is there if you use Mesa 20.3 or higher.

But the performance increase over a Raspberry Pi 4 is not that high. Especially if you boot the Rpi4 over USB SSD.

Panfrost is the driver for most Mali cards at this point.

Bifrost is the generation of card in the Odroid N2 and Khadas VIm 3.
The cards have these generations so far:
Utgard (Odriod C2 etc)
Midgard (Pinebook Pro etc)
Bifrost (Odroid N2 etc)
Valhal (none we support yet)
Odin (seems to be the one coming in rk3566 and rk3588 based SoCs)

1 Like

Okay guys.

I think it’s time for my little experiment to stop for this time.

I’ve been on my Odroid for the last 2½ months and the last month has not really yielded much improvement.

So the OpenGL acceleration for Plasma is still missing.
Ethernet speed is not as it should be.
Storage speed is lacking, since the eMMC is not that fast, comparing to the NVME in my top.
Storage amount is also lacking, since the large eMMC modules are expensive.
No Steam games is not really an issue, but I do like to play some things once in a while.
Overall performance is something that has tested my patience over the last couple of months. :stuck_out_tongue:

If you have any questions about my experiment, that I have not addressed in this thread, please ask. :slight_smile:

What does that mean? Even on my RPI4, I turn off the compositor, and GL works fine here. Is that what you’re talking about, or is there no acceleration for moving windows around etc?

I was thinking of getting the N2+ but the network speed thing concerns me a bit. I was planning on rolling on an SD card because, well, quite honestly SD cards offer very good random access speeds even if they’re sub HDD speeds on sequential reads.


What’s the current state of the Manjaro ARM games repo?

Rpi have gpu driver support, N2+ GPU drivers are still in wip, we expect it to be stable with 5.11 kernel.

What do you plan to run in it? I don’t think there is anything more powerful than s922x in arm arch in sbc category.

You can check it in the games repo thread you can see the updates there.

Quick update again. :slight_smile:

I installed linux-rc from testing branch (since my odroid is on that branch and the new mesa-git from unstable.

Now panfrost hw acceleration in Plasma “works”. It’s still slow, and needs optimization. But it’s there. :slight_smile:

The network speed issue, seems to be on a per connection basis, since downloading stuff via torrents, use my entire bandwidth, while downloading through wget or browser only gets me around 400-500 KB/s on average. So it’s a weird issue and not something I can directly connect to the Odroid itself.


A desktop. No real goal other than to have something faster than the pi4, and to gain more exposure to arm. The pi4 isn’t bad, not at all.

I’m still having trouble grasping what is / was wrong. Was general window management and moving/scrolling slow or was it just composition and eyecandy?


Compositing/OpenGL rendering of the Plasma desktop didn’t work. But it does with the new mesa-git and linux-rc.

Cool. It’s an interesting situation on RPI4 right now as with compositing off, full screen hardware accelerated 1080p60 works great, but with compositing on in any fashion, it slows down and drops frames. The flip side is without compositing on, windows video can have tearing, and to what degree changes all the time and I’m not sure why. I essentially run with compositing turned off as everything is faster and if I want perfect vid I just full screen it.

OpenGL/Compositing is not the same as video acceleration. They are done by 2 different parts of the GPU.
But enabling compositing can impose a performance hit on video playback, especially if the video playback is not accelerated, which is the case on Manjaro.

I was under the impression that I had hardware video decode enabled. It claims to be on in chrome and I have /dev/video* devices. The compositor is enabling a form of vsync. Not sure how it all weaves together honestly.

I just have bought odroid n2 plus, and i think this is the best point to ask my problem i run into;
How do i set the cpufrequency?
With the RPI4 ist was in /boot
Here i cannot find it, all debian based say its config is in /boot/ or /flash/
but when i fire up a >> find / -name “*.ini” << there is nothing useful.
If you could help me with that, i be happy so far. Everything i use is working like charm.

happy greetings