[Experiment] Using an Odroid N2 as my desktop

I know lots of these boards are catering for the hobbyist market, but I’d happily pay £200+ for a board with all the above features.

The RK3588 looks interesting. 8nm fabrication process, dual monitor support, big.LITTLE topology the ‘good’ way around. No word on M.2 support or RAM amount/speed yet though:

Two weeks in

Okay guys.
Here we are. 2 weeks into this little experiment. So a little update on how it’s going.

So far, I have only booted into my desktop PC once, in the last 2 weeks. And that was to test if a Manjaro ISO was working, not even to my “real” install.

All the previous pro’s and con’s still hold water.

  • I haven’t gotten a bigget eMMC module yet (but it’s in the mail).
  • I succesfully got Panfrost to work, but only on wayland session, where it’s buggy as hell. Not usable.
  • I have now tested on 1080p monitors as well. Makes no difference in the laggyness I experience in Element. So not certain what’s wrong there, since I had almost as much lag when using the Rock Pi 4 on 1440p monitor.

Kind of thinking that a RockPro64 with the metal casing, would be better performance wise, since it has Panfrost, USB-C and pretty much all the other benefits the Odroid has.


I think a RockPro64 + the PCIe expansion board for an NVMe SSD might be the sweet spot for now. You’d lose a bit of processing power, but the SSD might make up for it.

Yeah. The raw CPU performance loss is that great, compared to the gain of an nvme SSD over PCIe. :stuck_out_tongue:

Update time!

I just uploaded a new mesa-git package to unstable branch. And this is huge!
Because this update actually enabled Panfrost support on the G31/G52 boards. This includes my Odroid N2.

So I now have GPU acceleration on my Odroid, which has made Element really smooth. So that issue is no longer present.
Plasma however does not really support it yet. Meaning it crashes Kwin/Plasma on login if I enable 3d acceleration in Plasma. But if I use software rendering in Plasma, the apps still seem to be using panfrost, which is great. :slight_smile:


Hehe, I wonder how Wayfire or Sway will work :slight_smile: At least if the stability problems are in Kwin for now

Pretty sure atleast Sway works just fine. But I’m not a tilingWM guy, so I won’t be able to test for you. :stuck_out_tongue:

Oh, I’m perfectly happy with my stacking Wayfire thank you very much :stuck_out_tongue: I was thinking if it worked well for me (after some setup) it could work well for you too.

Here are my settings:

I should get a list of the packages I’m using. It’s the kb shortcuts that will need refinement the most (I’ve stuck with the pre-super key fix setup for far too long…)

I’ve installed Wayfire over Plasma on my PBP

I will look more into Wayfire, when they get to a more “stable” release.

If you have any suggestions to our Wayfire edition, please let me know. I haven’t tested it in a while. :wink:

I haven’t had time to use the PBP much lately. Let alone make checks on Wayfire specifically.
But improvements on that image are definitely on my mind :smiley:

For stability… Personally, I find it more stable than Plasma or XFCE. I compile stuff only in tty2 or Wayfire. It’s not feature rich (cough, I use nmtui for wifi connection as there is no widget, cough) but I have no complaints when it comes to being stable

Week 4 update

Okay, after 4 weeks usage a few things have changed.

  1. Panfrost now works, with mesa-git.
  2. Device now has 1-2 second lag every 10-15 seconds, making doing anything very annoying. I suspect my eMMC might be at cause.
  3. Ethernet speed is back to normal.

Hm. Changing keyboard and mouse, seems to have solved item number 2 in the above list.

1 Like


The Odroid n2 user I am is late to post a message, sorry, congratulation for this topic and the reports.

The wifi and the sound are working with the usb modules devices, design and sell by Hardkernel.

Sorry for the sale links, but it’s the only solutions I found to solve those missing modules.

I don’t use Wifi on this device, as I have an ethernet available, but I do use USB headphones, which works flawlessly. :slight_smile:
It is just the onboard audio cards, that are not present.

I agree with you, I use the rj45 too, and sometime I need the sound.

A month in

Okay. The first month has passed. And a few things have been ironed out.

  1. I finally got a bigger eMMC module, so now I feel like I have some things I can do, so I am not storage limited s much. 64 GB is still small though. :wink:
  2. Panfrost is coming along nicely. Bifrost support might make it into Mesa 20.3 release, or at least early support.
  3. I found a kernel patch to get support for 2K (1440p) monitors going, included with linux 5.9.9-2.
  4. Still no onboard soundcard detected. Asked @tobetter from Hardkernel for pointers.
1 Like

Do you still miss your desktop for some things, or have you gotten used to working on ARM?

Only thing I can’t really do, is play games. :slight_smile: Like Steam games that I use to play.

I am doing the same experiment at the moment but with a raspi 4b 4gb. Ssd connected to usb3 and you have enough storage space. But I would like to have a little bit more cpu power. The odroid n2+ looks nice but unfortunately it has only 1 hdmi out and I have a 2 screen setup.

Maybe the rockpi 4C could be the right thing.

Not a bad compromise, although I can’t say as I’ve tried it. I use a Pinebook Pro most days, and the only downsides to that are the keyboard and trackpad. Otherwise, it’s the same CPU and GPU as the Rock Pi 4C.