Executable default accidentally set to open in text editor

I wasn’t paying attention as I was in a rush…

Downloaded from TOR website, as advised.

Now my shortcut start-tor-browser opens up in Kate text editor.(facepalm)

How do I reverse my idiocy now?

Properties -> Permissions -> Allow executing file as program

Cannot see such option.

What DE and file manager do you use? Usually you can right-click > Open with… then choose the program and select “Always use this program” or something similar.

1 Like

I presume you mean a link to the program in a panel, menu or on desktop?

I get a checkbox on right-click → Properties:

⌷ Is executable

I’m using KDE as I guess you are as you have Kate.

… But see the :arrow_up: comment by @mbb re. Open With.

1 Like

I somehow didn’t think it would work this way, I located the folder, picked start-tor-browser and voila!

1 Like