Every game runs slow-mo

Hello everyone! This is my first post and I’m new to the distro so I’ll try to be as detailed as I can but please be patient and let me know if I am doing something wrong.

I am on latest Manjaro version and installed Nvidia Drivers during OS installation, I installed Steam (flatpack because when searching on how to install it, thats the 1st option that popped in the research. But I’ve learnt there’s a “native client” too. But I don’t really know yet the difference), I enabled Proton in Steam (Tried vers 8.0 and experimental).

After that, I tried playing light games like Death Must Die and Marvel Snap. They boot, but actually they seem to run in slowmo, like very low fps most likely or idk.

My HW is i7 8700K and Nvidia 2060s.

I’ve seen people on the forums being able to play heavier games so I wanted to know if I did something wrong? Maybe I should reinstall the drivers from elsewhere? Try the native Steam client? Something else I don’t know about?
I am new to Linux gaming and I just wanted to play some light stuff when I’m not on Windows.

If there’s something I need to provide you in order to make it easier for you guys to give me some hints just let me know.

Thanks for reading.

tldr games run in slowmo idk what to do :T

Use the Standalone Steam installation, from the repositories, to avoid issues with the other installation methods like Flatpak or whatever.

Steam should even have been installed right from start, it is a default package of the ISO as far as I know, unless you have done a minimal ISO installation.

As you have the Flatpack intallation, even if you remove it you will probably have installed game files remaining, you probably could move them to the default Steam folder then afterwards.

First provide system information with inxi -Fazy and mhwd -l && mhwd -li

Can’t hurt to look at Protondb.com to make sure where the problem relies on.

It looks that Death Must Die have a big issue for many people on Linux:

Its normal that fresh released games probably runs bad (specially on Linux), they need to be optimised from Steam Proton and this can only happend after the official release.

I recommend to wait for a first discount and in the mean time the game developer polished the project and you also archive a better game experience with Proton.

Copy+paste from ProtonDB for your marvel game:
Steam Flatpak refuses to let game open a webpage, which is required to login and start playing. Issue does not occur on Steam Native and runs perfectly there.

1 Like

First of all I thank you for the reply. I’ve had already checked both games on ProtonDB but I forgot to specify. I get that for Snap, and I will try putting the native app. But for Death Must Die as you can see, it should run so idk.
Also seeing that the problem I had with both games was the same, I didn’t really think it was a game specific issue to tweak. While flatpak steam doesn’t open the webpage for the game login (which I get), the issue was that even before reaching that point, the game was already running x0.25 speed.

This is why my question was more oriented towards tips about drivers or idk what else.
Maybe you could tell me some games you run on Manjaro rn without issues and if I have them I can try to launch them?
Also, would you advise me to use flatpak steam or native one? For general purpose? Without considering the marvel snap thing

PS. Also I think that if it was something strictly software related I’d have some error logs somewhere or on console I guess…

I will provide sys info when I can and update you. As for Steam, I don’t really recall if it was already there or not. I will remove flatpak and install the native one hoping it goess smoothly and let you know that too. Thanks for replying.

I wonder how you had Manjaro installed, was it minimum installation iso? Because if not, per default you should had Steam pre-installed from the official Repo’s.

Since 2020 i have Manjaro standard installed,out of the box i could play native Linux games like Beyond All Reason (open source/free to play) with superior performance against Win10. I’m not sure if there are maybe some missing packages/drivers from your possible minimum installation… i don’t have the experience in this direction.

Im personally didn’t archive any experience between flatpak/appimage and repo Steam.
Im just used the pre-installed Steam from the official Repo’s and activated Pre-shader and Steam Proton Experimental and thats it… My games which i try’d to play was running good/okayish if i compare the performance difference to windows, no really big issue.

My biggest issue that i had was the EXT4 Partition for my Steam Library, because i wanted first to share my Steam NTFS Library (Partition) but that isn’t so easy to archive.

Monsterhunter World, Kena Edge of Bridges, Home World Remastered collection, Pinball FX3, Warpips, Final Fantasy VIII Remastered, Deep Rock Galactic this are my Steam Proton games… that im using under Linux actually… all are running good/okayish and some games don’t have to hide against Windows.

We could help you better if you post your System settings in this Forum.

inxi --admin --verbosity=7 --filter --no-host --width

I have a i7-6700k + nvidia 2080Ti and i also use KDE btw.

nxi -Fazy                                                                                                                                                                                                                  
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "it_IT.UTF-8",
        LC_IDENTIFICATION = "it_IT.UTF-8",
        LC_MEASUREMENT = "C",
        LC_MONETARY = "en_150.UTF-8",
        LC_NAME = "it_IT.UTF-8",
        LC_NUMERIC = "it_IT.UTF-8",
        LC_PAPER = "it_IT.UTF-8",
        LC_TELEPHONE = "it_IT.UTF-8",
        LC_TIME = "it_IT.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=b7e18646-d767-43ac-a6ee-c8c28f449224 rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: Z370 Pro4 serial: <superuser required>
    UEFI: American Megatrends v: P1.30 date: 10/24/2017
  Info: model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4386 high: 4400 min/max: 800/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4384 2: 4384 3: 4399
    4: 4399 5: 4397 6: 4399 7: 4400 8: 4327 9: 4399 10: 4393 11: 4392 12: 4364
    bogomips: 88824
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Gigabyte
    driver: nouveau v: kernel non-free: 545.xx+ status: current (as of 2023-11;
    EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
    built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: DP-2,HDMI-A-1 empty: DP-1,DP-3 bus-ID: 01:00.0
    chip-ID: 10de:1f06 class-ID: 0300 temp: 32.0 C
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: DP-2 pos: primary,right model: MSI G242 serial: <filter>
    built: 2021 res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x296mm (20.75x11.65")
    diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: left model: Asus VG248
    serial: <filter> built: 2018 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 drv: nouveau
    device: 1 drv: swrast gbm: drv: nouveau surfaceless: drv: nouveau x11:
    drv: nouveau inactive: wayland
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: NV166 device-ID: 10de:1f06
    memory: 7.78 GiB unified: no
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-9:4 chip-ID: 0951:16a4 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: proton0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  Local Storage: total: 6.6 TiB used: 29.69 GiB (0.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO with
    Heatsink 1TB size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7
    temp: 28.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC26 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT250MX500SSD1
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 010 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD40EZRZ-00GXCB0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 4004 scheme: GPT
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 29.69 GiB (13.0%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Alert: No swap data was found.
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: nouveau temp: 32.0 C
  Fan Speeds (rpm): N/A gpu: nouveau fan: 961
  Processes: 380 Uptime: 12m wakeups: 0 Memory: total: 16 GiB
  available: 15.56 GiB used: 5.91 GiB (38.0%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1268 pm: pacman pkgs: 1253 libs: 364 tools: pamac pm: flatpak
  pkgs: 15 Shell: Zsh v: 5.9 default: Bash v: 5.2.21 running-in: konsole
  inxi: 3.3.31
    ~       
> 0000:01:00.0 (0300:10de:1f06) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

This is should be the system info, hoping it can solve anything. If something’s wrong please let me know.

I wonder how you had Manjaro installed, was it minimum installation iso? Because if not, per default you should had Steam pre-installed from the official Repo’s.

I think I never realized it should’ve been installed and went for the flatpak without thinking. Anyway I just ran command to uninstal flatpak steam. Then I pressed “Start” and typed “Steam”. It was not there and it sent me to the packet manager \ store to “Install it” so I installed it from there. Now I’m trying to dl DRG and see how it works.

Well DRG gets me this

And Death Must Die gives me this:
and closes. When on the flatpak version it at least opened

You are using the open source nouveau driver. If you want to use your Nvidia card to play games, you need to switch to the closed source nvidia driver. The nouveau driver is not able to deliver any 3D performance.

See the wiki on how to switch:

1 Like
mhwd -l && mhwd -li                                                                                                                                                                                                          ✔ 
> 0000:01:00.0 (0300:10de:1f06) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI

Warning: No installed USB configs!

Trying again now.

Yeah it will work better with the Nvidia drivers installed I bet.

I just booted and Death Must Die works. DRG works too.
so I think we solved it?! Anyway, they don’t seem as smooth as on Windows, for obvious reason since they’re not native on Linux but it’s definitely doable! Also

@Kobold if you wanna do some Deep Dives, hit me up here Steam Community :: ★débbòle~

DRG has a random big FPS issue when the loading splash screen shows up in the first 10sec.

Did you activated Pre-Shaders in Steam?

I also recommend DX12, runs mostly better on Linux.

I also don’t see a swap partition, i recommend a 6Gbyte Swapfile… otherwise sooner or later your system will freeze when your 16Gbyte RAM are used… anyways, swapfile is mainly a stable feature.

Yeah for sure, it was nouveau open source GPU driver… its not for 3D Applications.

I’ll activate Pre-shaders when I get the chance. I’ll also make a swap variable. Would 6gb be enough in your opinion? I’ve looked into it and read about the file, but I think I could do the partition too

I think that 6Gbyte is a good sweetspott, create this swap partition when possible at the end of your drive… i had to extend my swap partition in the past for a heavy memory leak situation to 8Gbyte and it sucked a little that it was my second partition and it was bad to extend.

More is better from stable view point, less is better from performance view point… i have to add, from what i can see that Linux use the swap option much better than windows does.

I mainly see in Linux the swap option are only used when the Ram are fully used, while under Windows it can be already used even when the RAM not even this much utilised.

Another point is that Swap-Partition should be better than a swapfile btw.

I’ll keep it mind to make it at end of the drive. Even though on Manjaro wiki I’ve read its only relevant in case of HDD, I am on an SSD. Isn’t it right? I hope I’ll figure where to put it… Should be a matter of GPartition to create it and running commands in terminal to make it effective

Source? I think the opposite. Having a partition for SWAP makes it so it writes only on a specific area of the disk all the time, my assumption is that you do not want that on a SSD for example, but I might be wrong, maybe SSD’s partition are handled differently and there is no risk of writing over and over on the same area. The SWAP file is the way to go in my opinion you don’t touch anything regarding partition, just create a proper SWAP file according to how much RAM you have.

I would follow instruction and recommendation about SWAP here Swap - Manjaro

Hmm from my view of a technical standpoint and my experience, i think you are wrong.

I remember the option: Specially Samsung Software implemented Overprovisioning

That means, you never fully use max space from a SSD for Partition (unallocated), that the weared sectors can be swapped between each other. Im not 100% sure if i got this straight, its possible im wrong here :wink:

Since then, i always left 20% space unallocated on my SSD… and the best performance you archive anyways with a SSD that isn’t more filled then 70-80%, otherwise you lost alot performance.

I think the sweetspott is around 50-60% fill status related to optimal SSD performance.

Me as gamer, i always decided to buy a SSD thats big enough thats alot space always are unused.
But the truth is also, it depends on the Manufacturer and which controller are used…

There are SSD Models outthere, which doesn’t loose 70% performance when they are 95% filled.
But the most SSD are trash then, i saw performance from a SSD with even lower HDD speed from around 80-120MB Write Speed… Im not sure if Read Speed also degraded then or not.

I’m not 100% sure, where i had this information… but i think it was in a arch tutorial, they cleary recommend to “NOT” use a swapfile there, i wasn’t a fan of this information at this time, because had to reduce my root partition and i also had to change a GRUB and also a FSTAB entry.

Edit, I found the old info:
Here the Source and the real statement from Linux Torvald (Why i decided to use Swap):


Reason: Linus Torvalds says that swap partitions are preferable: “all the normal distributions set things up with swap partitions, not files, because honestly, swapfiles tend to be slower and have various other complexity issues.”

I know this statement is “disputed” but even if its true or not, i personally think Swap-Partition is atleast no downgrade… and when its possible that its a upgrade, i choose swap partition then.

Not sure we understand each other, whatever no need to continue on the topic, I have nothing more to add to that.

Ok, to be fair he was replying also because of the initial issue, a big bug in kernel 5.12-RC with SWAP files. I will still use SWAP file for SWAP on my side. besides avoiding a potential bug one day regarding SWAP file, I still think it is superior to a partition because you can easily manage it (change its size, for example).

You can change its size easier, thats a pro… im agree.
But its also the only pro, i wouldn’t call it superior.

No need to hype it :wink:

I don’t have the need to change it size all the time… and maybe there is a reason why the Manjaro Installer (Calamares) decided for default installation the Swap Partition instead a Swapfile.

Do you know? I don’t… :thinking: