Ethernet connection randomly disconnects, "reason: 'carrier-changed"


So my ethernet connection is unstable, I get a notification in KDE about “Interface unavailable” and the icon changing to a red X. I’ve been trying to troubleshoot this for like 2 months now, and I’m at my wits end.

At first I thought it was an issue with my VPN, mullvad, that had messed with the network drivers somehow, so I’ve uninstalled that, and the problem persists.

When googling the problem I found this link:
It was the only thing I could find. So I tried that and it doesn’t seem to help. I still get the errors but I can’t tell if they are less frequent because of this file.

Then I thought it was something to do with DHCP, because in the logs it says “dhcp4 (enp0s31f6): canceled DHCP transaction” sometimes. So I’ve set up a static ip address in my router, and changed the DHCP lease to 1 week, and while that seemed to help reduce the frequency of the problem, I still get these “interface unavailable” messages in KDE.

Now I’ve bypassed the router completely, so the WAN cable in my apartment is connected directly to my computer. I’ve only had it like this for a day, so july 9th to today, july 10th, and still had disconnects because of this.
I could swap my current router to my previous one, but since I still have the issue even without a router I don’t think it would make a difference.

Also I’ve tried settings in NetworkManager to require IPv4, and disabled IPv6, to requiring IPv6 but I don’t think it made a difference. Can change if you think/knows it makes a difference of course.

Here are logs from july 8th to 10th of july, if you’d like more I’d be happy to provide. july 8th to july 9th July 10th

If there’s any info I’ve missed I’d be happy to provide it.

Thanks for your time!

Here’s inxi -v7azy:

  Kernel: 5.18.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=4ea405d0-e12a-40a1-a0cd-50f60fb3aaa2 rw quiet apparmor=1
    security=apparmor resume=UUID=34cf6ca9-63b8-429f-ae57-440bb598ecde
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: STRIX Z270H GAMING v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1301
    date: 03/14/2018
  Message: No system battery data found. Is one present?
  RAM: total: 15.57 GiB used: 7.19 GiB (46.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3311 high: 4500 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2800 2: 2800 3: 2800
    4: 2800 5: 2800 6: 3533 7: 4457 8: 4500 bogomips: 67224
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
    hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm
    lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
    pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer
    vme x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Micro-Star MSI
    driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Pascal process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 93 s-size: 1049x292mm (41.30x11.50")
    s-diag: 1089mm (42.87")
  Monitor-1: DP-0 pos: primary,right res: 1920x1080 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  Monitor-2: HDMI-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 94
    size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 515.57
    direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 4.53 TiB used: 620.48 GiB (13.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Intel model: SSDSC2KW360H6
    size: 335.35 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: G200 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Corsair model: Force 3 SSD
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 5.07 scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Seagate
    model: ST4000VN008-2DR166 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B type: HDD rpm: 5980 serial: <filter> scheme: GPT
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SH-222AB rev: SB01
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 94.36 GiB size: 92.32 GiB (97.84%) used: 60.21 GiB (65.2%)
    fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A
    uuid: 4ea405d0-e12a-40a1-a0cd-50f60fb3aaa2
  ID-2: /SSDs/860 raw-size: 363.29 GiB size: 356.53 GiB (98.14%)
    used: 206.25 GiB (57.9%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: 860
    uuid: 60a6d533-4291-493f-9fde-d9489505c37d
  ID-3: /SSDs/SSekunDary raw-size: 335.35 GiB size: 329.02 GiB (98.11%)
    used: 307.96 GiB (93.6%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
    label: SSekunDary uuid: 66644ad6-0a7e-4a8e-8b39-9ccb493fc3af
  ID-4: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33 label: N/A
    uuid: FB46-C1B1
  ID-5: /home raw-size: 102.47 GiB size: 100.3 GiB (97.89%)
    used: 45.59 GiB (45.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: 860home
    uuid: 4d985cd5-acfe-4a96-9ee5-1de620c1f440
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.13 GiB used: 471.8 MiB (2.7%)
    priority: -2 dev: /dev/sdc3 maj-min: 8:35 label: N/A
    uuid: 34cf6ca9-63b8-429f-ae57-440bb598ecde
  ID-1: /dev/sdd1 maj-min: 8:49 size: 3.64 TiB fs: ext4 label: veryBig
    uuid: 467fef4a-d6b0-4396-a49d-82307fc9e72c
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: Valve Wireless Steam Controller type: Keyboard,HID
    driver: hid-steam,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 28de:1142 class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-4:2 info: ASMedia ASM1051E SATA 6Gb/s bridge ASM1053E ASM1153
    3Gb/s ASM1153E bridge
    type: Mass Storage driver: uas interfaces: 1 rev: 3.0 speed: 5 Gb/s
    chip-ID: 174c:55aa class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Kingsis ZOWIE Gaming mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 1af3:0001 class-ID: 0301
  Hub-4: 3-2:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 3-2.2:4 info: Cypress Gaming keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 0665:6000 class-ID: 0300
  Hub-5: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
  Processes: 269 Uptime: 3h 16m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: 1776 pacman: 1715 lib: 511 flatpak: 51 snap: 10 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.19

How does your local network looks like ?

Uh, do you mean what devices are connected or how the cables are wired in my apartment?

I mean:

I have a Modem/Router → Firewall → Router (to that Router, the 3 computers and a printer is connected).

The connection problems can caused by …

Oh, I have a router/modem → my computer.

is the cable OK? Maybe test with a different one. And also use different ports at the router.

Yeah i guess it was something to do with the cables, I’ve been messing with ports on the router and the cables to my computer and somehow it seems to have helped. I dunno, im back at the previous port and it seems fine now?

I got like one similar disconnect but I guess its something to do with the cables.

Thanks for the suggestions everyone!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.