Ethernet Connection Drops After Restart and Suspend

Hello. Everyone. I recently installed manjaro and have been having Ethernet issues. Sometimes after a restart, it works, but most of the time, gnome settings says cable disconnected. However, if i run systemctl restart NetworkManager, it says connecting but then says network failed. I am not sure if it is related, but in dmesg, it says that r8619 0000:04:00.0 enp4s0: renamed from eth0.

Thanks in advance,
Brandon Feder

When this happens, could you run sudo modprobe -r r8169 ; sleep 1 && sudo modprobe r8169 and see if it fixes the problem? If your device is compatible, you could try the r8168 driver (install it using mhwd: sudo mhwd -i pci network-r8168).

I think that worked! Thanks for the help.

This works for me as well. I have the problem that dhclient times out after suspend (same with Network Managers internal and dhcpd).

Do we wait for a kernel/driver fix for this or do I need a systemd-service that reloads the module after each suspend?

I have network-r8168 installed.

Does it work for you permanently? Because I had disconnections about twice every system start. I did as in wiki:
Using dhcpcd Instead of NetworkManager section.
But to make it work after reboot I had to do:

sudo systemctl disable --now NetworkManager.service
sudo systemctl enable dhcpcd.service

sudo systemctl start --now dhcpcd.service
I don’t know if it is necessary but I also did
sudo systemctl daemon-reload

And I haven’t had disconnections so far.

Also sometimes it is worth restarting modem. It may be modem issue or damaged cable.

Maybe the NetworkManager itself is a problem in some cases. On other Linux forums I read that it happens, and they recommended to use wicd instead, but I haven’t tried that yet.
I am on Plasma.

It works permanently in the sense that every time I wake up the laptop from suspend, I have to remove the module and plug it back in (modprobe -r r8169 && modprobe r8169). This is not a permanent solution in the meaning that it’s solved.

I don’t think it’s a problem with a DHCP client or a networking manager (NetworkManager, wicd, or systemd-networkd), it’s probably in the driver. Any DHCP request times out, doesn’t matter which client is used (dhclient, dhcpcd, systemd-networkd, or NetworkManagers internal).

I hope in a future kernel (or driver?) release this will be fixed. Unfortunately, I don’t know when this was introduced, so we could create a nice bug report.

But is it configurable in modem or system or it happens in a non predictable way?

You have more knowledge about networking than me. Actually, I don’t have at all. I have had this problem for years with r8168. But I use desktop station not laptop and I am considering buying second hand intel network card to solve this issue.

I am not sure r8168, r8169 are still supported. A few years ago I was able to download new drivers from realtec but it is not possible anymore.
On old forum there was a thread about these drivers and someone proposed a patch but it wasn’t accepted. If you google it there is a lot of threads over internet about these drivers.

I found this

but I am not sure if I can trust network driver from third party site.

For me, it is predictable, such that when waking up, I have to replug the driver module for it to work. This is fairly recent, so I don’t believe that a user-patched driver from 5 years ago will solve that. Also, maintaining this is very hard. If there is no package in the official repository or the AUR, I would not install it.

For now, I’m living with replugging; or considering setting up a systemd service that does it automatically. But my guess is, that this is a bug introduced recently (maybe with 5.9?) and will be fixed eventually.