Ethernet connect issue on laptop (connecting and deactivating forever)

Greetings.

I’ve never had a problem with Manjaro for almost two years, but ethernet. This ethernet issue would appear once in a while and I have no idea what it wants. Don’t know for sure why it showed up this time(I guess after system update) and why it disappeared in the past.

I prefer to use wired ethernet connection on my laptop Hp probook 430 g5. No issues with wi-fi though.

Some outputs of commands from wiki.
lspci (ethernet part):

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Hewlett-Packard Company Device 8377
Flags: bus master, fast devsel, latency 0, IRQ 140
I/O ports at 3000 [size=256]
Memory at f0304000 (64-bit, non-prefetchable) [size=4K]
Memory at f0300000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: r8168

dmesg | grep r8168:

[ 13.864746] r8168 Gigabit Ethernet driver 8.048.03-NAPI loaded
[ 13.879391] r8168: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.
[ 13.881401] r8168 Copyright © 2020 Realtek NIC software team nicfae@realtek.com
[ 14.889409] r8168 0000:01:00.0 enp1s0: renamed from eth0
[15070.183385] r8168: enp1s0: link up
[15071.207123] r8168: enp1s0: link down
[15079.543133] r8168: enp1s0: link up
[15080.566820] r8168: enp1s0: link down
[15088.912902] r8168: enp1s0: link up
[15089.926589] r8168: enp1s0: link down
[15099.312669] r8168: enp1s0: link up
[15100.336324] r8168: enp1s0: link down
[15108.662362] r8168: enp1s0: link up
[15109.686084] r8168: enp1s0: link down

modinfo r8168:

filename: /lib/modules/4.19.138-1-MANJARO/extramodules/r8168.ko.gz
version: 8.048.03-NAPI
license: GPL
description: RealTek RTL-8168 Gigabit Ethernet driver
author: Realtek and the Linux r8168 crew netdev@vger.kernel.org
srcversion: 3D290B8867C584C2920F0E4
alias: pci:v00001186d00004300sv00001186sd00004B10bcsci*
alias: pci:v000010ECd00002600svsdbcsci*
alias: pci:v000010ECd00002502svsdbcsci*
alias: pci:v000010ECd00008161svsdbcsci*
alias: pci:v000010ECd00008168svsdbcsci*
depends:
retpoline: Y
name: r8168
vermagic: 4.19.138-1-MANJARO SMP mod_unload
parm: speed_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm: duplex_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm: autoneg_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm: advertising_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm: aspm:Enable ASPM. (int)
parm: s5wol:Enable Shutdown Wake On Lan. (int)
parm: s5_keep_curr_mac:Enable Shutdown Keep Current MAC Address. (int)
parm: rx_copybreak:Copy breakpoint for copy-only-tiny-frames (int)
parm: use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm: timer_count:Timer Interrupt Interval. (int)
parm: eee_enable:Enable Energy Efficient Ethernet. (int)
parm: hwoptimize:Enable HW optimization function. (ulong)
parm: s0_magic_packet:Enable S0 Magic Packet. (int)
parm: debug:Debug verbosity level (0=none, …, 16=all) (int)

95% of the time it’s a dodgy cable. Change the cable to a brand-spanking new one, please! :innocent:

If that’s not it, have you tried the 5.7 or 5.8 kernel yet as you seem to be on 4.19 and it might be a regression (=bug) in the driver…

:upside_down_face:

can you return

uname -a
inxi -nzx
1 Like

It seams you were right. Replaced the cable and it works.
I don’t have competence in kernel at all. Only once I switched to a newer recommended version 5.4 but didn’t notice any difference and switched back as I believed was the standard version 4.19. Versions 5.7 & 5.8 are not recommended you think I should give it a try?

uname -a

Linux my-machine 4.19.138-1-MANJARO #1 SMP Fri Aug 7 09:36:31 UTC 2020 x86_64 GNU/Linux

I’ve marked my answer as the solution, however, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

It depends on your hardware: if everything works, keep what you have until November 2024 (one month before it goes EOL). If you would add newer hardware in the future, remember that newer hardware is supported by newer kernels only…

:innocent:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.