Etherape issue with shared library

Hello everyone,

Brief intro on my behalf,

Been using Manjaro for 2 years now & loving it, but, still not that comfortable with Linux … Always solved any issue i had by looking in forums .
This issue i couldnt find a thing, so made an account … wasn´t sure in what section to make it, so i droped it here…

Got an issue with etherape after this last update.

kernel is 4.19

etherape: error while loading shared libraries: libgoocanvas-2.0.so.9: cannot open shared object file: No such file or directory

Thought i could solve it by reinstalling it …

sudo pacman -R etherape
sudo pacman -Syu && sudo pacman -S etherape
sudo etherape

epic fail :upside_down_face:, got same msg …

Any ideas ?

@nightmare-2021 eitherape needs a rebuild against goocanvas 3.0.0.

Rebuild is done

thx for replying.

And on my end ? im a bit unexperienced, especially withthese kind of things.

What am i supposed to do ?

Some help ? pls :slightly_smiling_face:

I feel this is so so so above my paygrade …nevertheless, my 2 …bits…

they updated libgoocanvas, and now etherape needs it to run… thats clear, its a shared library and now i need to compile etherape again ?

$ whereis etherape
$ ldd -v /usr/bin/etherape

i get a huuge output & dont see any libgoocanvas 3.0.0-1 …

& now i do what ?

etherape 0.9.19-2 is now available in all branches so you’ll see the update when your mirror has it.

Thx for your reply

This morning, when i saw both your replies, i did a sudo pacman -Syu & got nothing… did another after i saw your reply and just got an kiconthemes update …

But now i know its just a question of waiting …

Thx again :slightly_smiling_face:

P.S. i stopped at ldd -r /usr/bin/etherape

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.