/etc/default/grub: line 1: GRUB_DEFAULT=saved: command not found

I took quiet out of the GRUB_CMDLINE_LINUX_DEFAULT line and when I ran update-grub I get this:

/etc/default/grub: line 1: GRUB_DEFAULT=saved: command not found

If I change it to GRUB_DEFAULT=0 and either comment or change GRUB_SAVEDEFAULT to false and then run update-grub I get the same thing:

/etc/default/grub: line 1: GRUB_DEFAULT=0: command not found

I am only running Manjaro. Below are the first several lines of GRUB:

GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

What am I doing wrong? Thanks much for all the help.

it’s strange that your error says:
/etc/default/grub: line 1: GRUB_DEFAULT=0: command not found
but the option in your config file seems to be:

I can’t make sense of this discrepancy.

this should be a number - not a string
it refers to which entry is booted by default, when you do not manually change it at boot time
like this:

My system has GRUB_DEFAULT=saved as the first line in /etc/default/grub and I never saw this problem.
Documentation says it’s ok to use strings here and mentions saved as special string: GNU GRUB Manual 2.04: Simple configuration

Somehow that line isn’t properly recognized. Did you copy+paste it from somewhere? Try deleting it completly and re-type it manually.
Could also be a potential encoding problem when you edited that file. What editor did you use? Check what file has to say:

$ file -bi /etc/default/grub
text/plain; charset=us-ascii
1 Like

I remembered it wrong from when I tried to make the third line (the standard second kernel) the default some time ago.
I should have looked up the manual before appearing to be certain.

is what is in my configuration right now


Thanks, I’ll give it a shot and let you know how it goes. Fingers crossed!!