Espeak-ng can't find voice files

I’ve recently installed espeak-ng and speech-dispatcher. Testing spd-say worked fine. However, when I tried espeak-ng -v mb-en1 "Hello", I got an error back stating mbrola couldn’t find the voice file and that there was no mbrola executable. I later installed mbrola from the aur, which got rid of the “no mbrola executable” error, but espeak-ng still said it couldn’t find the voice file. The error is as follows (after installing mbrola):

Cannot find MBROLA voice file 'en1' in neither of paths:
 - /usr/share/mbrola/en1
 - /usr/share/mbrola/en1/en1
 - /usr/share/mbrola/voices/en1
Please install necessary MBROLA voice!
mbrola: FATAL ERROR : cannot find file en1 !
mbrowrap error: mbrola closed stderr and did not exit
Error: Could not load the specified mbrola voice file.
Error: The specified espeak-ng voice does not exist.

The problem is that there are voice files under /usr/share/espeak-ng-data/voices/mb/, but espeak-ng can’t find them and I don’t see any way to tell the program to look in that directory. I eventually installed mbrola-voices-us1 from the aur just to get something other than the default voice. Does anyone have any idea what’s going on and how to tell espeak-ng where the voice files are? I tried making the mbrola directory under /usr/share/ and making a symbolic link to /usr/share/espeak-ng/voices/mb/, which is where the files are, but that didn’t work.

Thee links might help:

However, I cannot.

Good luck.

1 Like