Eschalon: Book 2 saved games location

I’m having a hard time finding where the saved game file with the game Eschalon: Book 2. Found it yesterday but closed the Firefox and Thunar tabs. A helpful game forum provided me with this info.

Yes I have the game on Steam. This game is installed on an external drive.

I used a Character Editor to give me a head start.

Does anyone know?

PCGamingWiki is your friend:

1 Like

sorry that is not providing me with anything useful. But thanks.

Does installing the game on a external drive vs the System on matter?

You’ll thank me later when you finally realize it actually was useful. :stuck_out_tongue_winking_eye:

No, because Windows games installed via Steam are still installed in a Proton prefix no matter the library location.

So since I had to use compatibility layer in Steam the I got the Windows version instead of Linux?


FYI, there are quite a few “Linux versions” that are just half-arse ports with an ancient version of WINE embedded that do not work well–if at all. Using Proton works much better. Examples are Rise / Shadow of the Tomb Raider.

See Eschalon: Book II on ProtonDB:

Not to bother you but that is not technically correct. When you install a Windows game with Proton in Steam, the game is installed in the [LIBRARY LOCATION]/steamapps/common/[GAME NAME] folder and it creates the Proton prefix in [LIBRARY LOCATION]/steamapps/compatdata/[APP ID].

Just for clarification, they are two different locations within the library location.

So the place to look at is at the same place as in Windows, but in the corresponding Proton prefix location. So what did it say on the link given to you above for the save game location?

Windows %APPDATA%\Basilisk Games\Book 2 Saved Games\slot*\

So go for it in the prefix folder corresponding to your game, find this location, it should be easy to find.

My point was the path inside the prefix remains the same–not related to the library location. :wink:

I’m using a ext. HDD for Steam and use Steam Compatibility mode due to the Linux Client is no longer updated. Since I have Eschalon Book 2 and using a Windows based Character Editor to get a better start, I’m lost where the savegame is at. With the Book 1 I was able to to use catfish to find the location. Found it with EB2 and forgotten where…

If I do manage to find this again, create a link…

What omano just said is

[LIBRARY LOCATION]/steamapps/compatdata/[APP ID]/[Proton %APPDATA%]/Basilisk Games/Book 2 Saved Games/slot*/

In this, [LIBRARY LOCATION is by default ~/.local/share/Steam but something you may have adjusted, [APP ID] for this game seems to be 25620.

%APPDATA% is in Windows normally C:\Users\<username>\Appdata\Roaming and would for Proton be pfx/drive_c/users/steamuser/Appdata/Roaming. So, together,

~/.local/share/Steam/steamapps/compatdata/25620/pfx/drive_c/users/steamuser/Appdata/Roaming/Basilisk Games/Book 2 Saved Games/slot*/

… in which you as said substitute the correct library location for ~/.local/share/Steam and where the rest is probably okay as is. If not, just do e.g.

find ~/.local/share/Steam -name "Basilisk Games"

to be pointed in the right direction, of course again using the correct library location.

Here is the kicker. I still have the older saved games from the first few times I played the Eschalon Trilogy. But they are Linux Native. For some reason SteamPlay puts them elsewhere…

Why didn’t Valve setup the Linux Client to put all the saved games in one Folder in /home/“User”/Steam Games/…
in the first place? Without the “.” which just makes it hard find those files.

It’s not Valve/Steam that decides where a game not developed by Valve stores its savegames. It for the sake of Steam cloudsaves sometimes knows where a specific game stores its savegames, but the game still does its own savegame storing/reading/management.

In the case of the Windows (version of the) game “Eschalon: Book 2” that game seemingly stores to under %APPDATA% as per above; in the case of running said Windows game under Proton it still as far as the game itself is concerned stores in that same location, although it now from the outside translates to the mentioned path under the game’s library location.

And note again that ~/.local/share/Steam/ is just the default library location. You said you in fact installed into a different/secondary library location on an external drive, presumably as added via Steam’s Preferences → Downloads. You need to substitute for that part – and there’s no dots in the rest of the given path.

I should have put commas around the trailing dots. :man_facepalming: