'Esc' key set as shortcut for audio volume widget

I am currently using my personal Lenovo laptop with the KDE Plasma DE. Everything is great except that everytime I restart my computer the ‘Esc’ key gets set as the shortcut for the audio volume control widget in my system tray. No matter how many times I go into the shortcut settings and delete this shortcut, or set it to something else, when I restart the ‘Esc’ key is back at it with these shenanigans.

Please help me stop this madness.

You mean this shortcut ?


Make sure you set your session to start empty

so it not getting the settings from the previous session …

Thanks for the reply. It is indeed the keyboard shortcut you indicated. My Desktop session settings are currently set to ‘Start with an empty session’. I don’t think I ever set the shortcut to be ‘Esc’ but may have accidentally done it at some point.

Take a look inside the following files:

  • ~/.config/kglobalshortcutsrc
    for this content there:
    activate widget 9=Esc,none,Activate Audio Volume Widget

  • ~/.config/plasma-org.kde.plasma.desktop-appletsrc
    for this content, or something similar:


and delete them manually, save the files, log out and back in.

1 Like

Thank you so much! This did the trick. Previously, I tried to tinker with ~/.config/kglobalshortcutsrc and set activate widget 9=none,none,Activate Audio Volume Widget but this didn’t really work. After making your suggested edits and restarting, things seem to be back to normal. Thanks again!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.