Error : you need to locate the kernel

I was updating the system after long time no use
Using “-Syyu”
Internet disconnected and update stopped.
Re connected and pacman says 10 updates available.

The mouse was lagging so i restarted the system.
Grub shows but

‘/boot/vmlinuz-4.19-x86_64’ not found

How do i fix this?
Tired to edit the “4.19” to “5.7”
But didn’t work.

How long a time? As a user of a rolling distribution you are expected to update your system on a regular basis.
You can try to fix this:

  • boot from Manjaro live iso (usb)
  • manjaro-chroot -a into your installation
  • manually copy the kernel to correct location: cp /usr/lib/modules/4.19*/vmlinuz /boot/vmlinuz-4.19-x86_64

A good practice to start doing is to use Timeshift and create a restore point before doing updates or any major change to your system. Then you can restore back to that point if needed.

Do i make a live usb with 4.19 version or newer version?

As far as i can understand the kernel was updated from 4.19 (old) to maybe 5.7 (current?)

So i thought i should just relocate the current version

Lesson learned

If you already have one usb ready - simply use that one. Else always use the latest official iso.

I don’t think so, 4.19 is an LTS kernel and available and perfectly viable choice of kernel. It would not have been removed automatically.
I suspect you had too long an update pause for your system and therefor some pacman hooks weren’t in place when the 4.19 kernel got updated (which would have copied the kernel to /boot).

1 Like

For some reason, the live usb doesn’t boot!
I tried Rufus (with dd mode)
And tried (dd command from different manjaro distro)

sudo dd bs=4M if=path/manjaro.iso of=/dev/sdb conv=fdatasync  status=progress

It just shows a black blank screen with the word grub and it disappears immediately.

That’s in fact very true!
Maybe a year or sth.

Did you check the signature of your download?

If yes, download the previous one from the archive and try again because the latest and greatest also comes with the latest and greatest kernel…


nope. I didn’t.
I downloaded from the official site and didn’t think there is anything i should worry about. Just like every other time i downloaded manjaro.

  • Go to the download page and note the SHA1

  • execute:

    sha1sum ~/Downloads/yourdownload.ISO
  • check both are identical.

  • If not: you have a dodgy download: download again.

  • If correct, follow my previous advice:

They matched.
Seems like i will have another downloading trip.