Error with Libsodium

Good evening,
since 2 days i have a problem in using Visual Studio Code on my PC, running Manjaro. If I try to use the terminal in Visual Studio, I get the following terminal output (before I actually used the terminal at all).
ERROR: object ’ ‘/usr/local/lib/’ from LD_Preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: object ’ ‘/usr/local/lib/’ from LD_Preload cannot be preloaded (cannot open shared object file): ignored. I tried to fix the error with help of some other threads and even tried to ask GPT, but of course nothing was able to help me. Im looking forward to get help, from one of you. Me at myself don’t use Manjaro for a long time, because I just learned something about linux in school few weeks ago, so i am actually new in using linux. Maybe I get the error because of stupid stuff, i as a beginner don’t know about or there are different reasons. One of my ideas was, that the mistake occurs, because of different problems with node.js, because the problem started, when I began to use node.js. I want to say “thank you” for any help I will receive.

Friendly regards, from Germany.

PS: If there are german-languaged, who are able to help me, you could do it in german, you probaply noticed, that my english isn’t the best.

Well … thats not where libsodium puts it.

extra/libsodium 1.0.18-2

What package do you have installed exactly?

Is your package/system up to date?

I think it has to do with that … until then … you may be able to launch using something like

LD_PRELOAD=/usr/lib/ /usr/bin/code

~]$ node -v
ERROR: object ‘/usr/local/lib/’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

I reinstalled the version 1.0.18-2, even tried to download from github one time, because of the idea, that it could work, if I install it from there. My System is up to date too. You can see, that i get an error, after asking for nodejs, even if I just reinstalled the newest version of it.
Thank you for your answer @cscs.

You should try to find out why you had files in /usr/local/ . No package from the repository is installing in this folder. This folder is the default if you are trying to compile own libraries and binaries. So it is something you did to your system.

You can use ldconfig -p to find out if you need to rebuild the ldcache. If you grep thru it and find /usr/local/lib/ you might need to rebuild it with sudo ldconfig .

But you error looks more like as if you are using LD_PRELOAD in one of you config files that set ups your system. It might be a system wide config or a user config.

You can check it with echo $LD_PRELOAD .

I fixed the problem for me.
After I got a system Update for Manjaro, I used to try a way, I tried before the update.
How I did it:

wget https:/
tar -xzvf LATEST.tar.gz
cd libsodium-*
make && make check
sudo make install

Thanks, to everyone, who helped me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.