Error while loading shared libraries after Kernel Update

I am using Manjaro xfce on a thinpad x220. When I try to run npm I recieve this error

node: error while loading shared libraries: cannot open shared object file: No such file or directory

I believe this all started after I did a full system update that also updated my kernel. Looking in my pacman.logs I did find one warning from the kernel update.

[ALPM] warning: /etc/systemd/homed.conf installed as /etc/systemd/homed.conf.pacnew

However I am not sure if that is related.
Other things I have tried that have not helped:
running: pacman-mirrors -f 5 && pacman -Syyu
removing and reinstalling npm
querying the name of the library
Searching (pacman -Ss) for the library.

I am not the most experienced with linux, so if you need any more information for clarity please let me know. I will need this fixed for school in a few days so time is of the essence for me.

I fixed it. I had an outdated version of node because the recent version was giving me errors. It appears updating node has also fixed my problem with npm. Im assuming it is something with dependencies… man do I feel like a fool. I spent hours on this.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.