Error while installing ticktick-nativefier

Hello there,

I got this error while trying to install ticktick-nativefier from aur package AUR (en) - ticktick-nativefier

the error :
ln: failed to create symbolic link ‘/home/mohamed-g15/ticktick-nativefier/pkg/ticktick-nativefier/usr/lib/’: No such file or directory
==> ERROR: A failure occurred in package().

could you please help me

It can’t symlink the file to a directory that doesn’t exist. Let the AUR package maintainer know by leaving a comment.

For now edit the PKGBUILD and change line 33 to:

install -dm755 "${pkgdir}/"{opt,usr/{bin,lib,share/applications}}
1 Like

same error

Then you haven’t actually edited the PKGBUILD. How are you doing it?

the steps that I do

git clone AUR (en) - ticktick-nativefier

cd ticktick-nativefier

makepkg -si

I do these steps to install any package from AUR

The page URL and git clone URL are different. It should be:

git clone

Then before you do makepkg -si, edit the PKGBUILD. If you’re getting the same error, the PKGBUILD has not been modified correctly as I outlined above.

I am doing this command

git clone

sorry I didn’t express that in my reply

I tried again as you said exactly, but still I got the same error

You tried what again? Are you opening the PKGBUILD in a text editor, changing the line and saving the file before running makepkg -si?

Old (notice lib is missing):

install -dm755 "${pkgdir}/"{opt,usr/{bin,share/applications}}


install -dm755 "${pkgdir}/"{opt,usr/{bin,lib,share/applications}}

Oh sorry I didn’t understand you in your first reply.
Now I tried it and the error didn’t appear and the package installed successfully.
Thank you

I have added a comment in the AUR package, and the maintainer already submitted the proposed fix! Thanks you both for reporting and finding a solution.

@Mohamed-G15, please try to install the package again without any manual changes to the PKGBUILD, and post there if you find any other issues during the installation.

Thankee Sai.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.