Error when synchronising the databases

Today there is a big update, 1.9 Gb but when I open the package manager I get the message:
“Error when synchronising the databases”.
What should I do, update? I don’t want to have problems after the update.

Use the terminal:

sudo pacman-mirrors --geoip
sudo pacman -Syyu
1 Like

Working perfectly after the update.

Thank you very much!

Perfect. Note, that pacman doesn’t update the AUR packages (if you are brave enough to use any of them.)

You have to use another AUR helper: yay

Now I don’t know if I ever had to install anything from AUR. Is there any way to find out?

You can use pacman -Qm to list foreign packages. Usually these are from the AUR.

Exactly, it was the printer.
This is the list after pacman -Qm:
brother-dcpl2530dw 4.0.0_1-1
brscan2 0.2.5_1-1
brscan4 0.4.11_1-1
ceph-libs 15.2.17-1
gcolor2 0.4-9
libguess 1.2-4
libsidplay 1.36.59-10
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
metis 5.1.0.p10-2
systemd-fsck-silent 239-1

What should I do?

Most of the are redundant, and should be removed.

sudo pacman -Rcsu ceph-libs libguess libsidplay manjaro-documentation-en manjaro-firmware systemd-fsck-silent

The other ones, I don’t know and you probably intentionally installed them.

You might want to install yay as AUR helper and use yay -Sau to update these packages (if needed).

1 Like

Thank you very much again. I installed yay and everything is up to date now.
However, if I update the package manager I still get the same error message, I think something is still wrong.

Yes, it still is. Keep using pacman/yay for the near future.

1 Like

All right, I will do so. Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.